This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1073991 - Create Child resource with User Type for postgres server doesn't work correct
Create Child resource with User Type for postgres server doesn't work correct
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Other (Show other bugs)
JON 3.2.1
i386 Linux
high Severity high
: DR01
: JON 3.2.2
Assigned To: Thomas Segismont
Mike Foley
:
: 1079376 (view as bug list)
Depends On: 864351
Blocks: 1082792
  Show dependency treegraph
 
Reported: 2014-03-07 10:51 EST by Mike Foley
Modified: 2014-07-28 20:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 864351
Environment:
Last Closed: 2014-07-28 20:17:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2014-03-07 10:51:09 EST
+++ This bug was initially created as a clone of Bug #864351 +++

Description of problem:
Create child resource with type User for postgres server resource show failure  on child history as well as on logs and doesn't show created user (role), while it is created in DB. Uninventory / inentory of parent resource get the created child.

Version-Release number of selected component (if applicable):
JON 3.1.1.GA

How reproducible:
always

Steps to Reproduce:
1. Go to Postgres Server in Resources left menu
2. Create child resource type=User
3. Fill all data correctly and click Finish
  
Actual results:
"Plugin did not indicate a resource name for this request." error log is shown in child history log, child resource is not shown under Users resource as child resource.

Expected results:
Child resource is created and shown under Users resource.

Additional info:
screenshot attached.
Comment 2 Thomas Segismont 2014-04-09 12:08:44 EDT
*** Bug 1079376 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Segismont 2014-05-12 11:02:16 EDT
Cherry-picked over to release/jon3.2.x

commit d098915930e1e3873b7493dbf25e9f8c972bf378
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Mon May 12 16:54:27 2014 +0200
    
(cherry picked from commit 7b6b9f44ff4f7cf758ec25482e6cba83a818ce75)
Comment 4 Simeon Pinder 2014-05-22 11:15:38 EDT
Via product triage, determined that this bug is to be included for DR01 target milestone.
Comment 5 Simeon Pinder 2014-05-29 22:43:37 EDT
Moving to ON_QA as available for test in latest cumulative patch build(DR01):
http://jon01.mw.lab.eng.bos.redhat.com:8042/dist/release/jon/3.2.2.GA/5-29-2014/
Comment 6 Mike Foley 2014-05-30 15:30:52 EDT
Verified JON 3.2.2 DR1
Comment 7 Larry O'Leary 2014-07-28 20:17:14 EDT
This has been verified and released in Red Hat JBoss Operations Network 3.2 Update 02 (3.2.2) available from the Red Hat Customer Portal[1].



[1]: https://access.redhat.com/jbossnetwork/restricted/softwareDetail.html?softwareId=31783

Note You need to log in before you can comment on or make changes to this bug.