Bug 1074014 - Double OK when starting the service
Summary: Double OK when starting the service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: Kaushik Banerjee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-07 16:26 UTC by Jan Pazdziora
Modified: 2014-10-14 04:48 UTC (History)
9 users (show)

Fixed In Version: sssd-1.11.5.1-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Bash function daemon will call 'success' or 'fail'. It is useless to call them one more time. It may cause strange behaviour with some configurations of terminal. Consequence: When running service sssd restart, the [OK] is printed three times Fix: remove rudimentary call of 'success' and 'failure' Result: [OK] is printed 2 times
Clone Of:
Environment:
Last Closed: 2014-10-14 04:48:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1375 normal SHIPPED_LIVE sssd bug fix and enhancement update 2014-10-14 01:06:25 UTC

Description Jan Pazdziora 2014-03-07 16:26:25 UTC
Description of problem:

When running service sssd restart, the [OK] is printed three times.

Version-Release number of selected component (if applicable):

sssd-1.9.2-129.el6.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. Have IPA-enrolled machine so that sssd starts without errors.
2. Run service sssd restart.

Actual results:

# service sssd restart
Stopping sssd: [  OK  ]
[  OK  ] sssd: [  OK  ]
#

Expected results:

# service sssd restart
Stopping sssd: [  OK  ]
Starting sssd: [  OK  ]
#

Additional info:

Jakub suggests the culprit is

  daemon $SSSD -f -D && success || failure

because daemon itself seems to report the success.

Comment 1 Dmitri Pal 2014-03-13 12:53:20 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2280

Comment 2 Lukas Slebodnik 2014-03-19 14:30:36 UTC
I was not able to reproduce it
Steps done
1. Created new RHEL6.5 VM
2. Updated all packages
3. Installed package ipa-client
4. machine was enrolled to IPA
5. Run service sssd restart.

[root@vm-049 ~]# rpm -q sssd
sssd-1.9.2-129.el6.x86_64
[root@vm-049 ~]# rpm -qa | grep sysv
sysvinit-tools-2.87-5.dsf.el6.x86_64
[root@vm-049 ~]# rpm -qa | grep upstart
upstart-0.6.5-12.el6_4.1.x86_64
[root@vm-049 ~]# 
[root@vm-049 ~]# service sssd status
sssd (pid  1962) is running...
[root@vm-049 ~]# service sssd restart
Stopping sssd:                                             [  OK  ]
Starting sssd:                                             [  OK  ]
[root@vm-049 ~]# service sssd stop
Stopping sssd:                                             [  OK  ]
[root@vm-049 ~]# service sssd restart
Stopping sssd: cat: /var/run/sssd.pid: No such file or directory
                                                           [FAILED]
Starting sssd:                                             [  OK  ]

Could you compare version of installed packages?

Comment 3 Jan Pazdziora 2014-03-20 07:27:36 UTC
[root@mgmt3 ~]# rpm -q sssd
sssd-1.9.2-129.el6.x86_64
[root@mgmt3 ~]# rpm -qa | grep sysv
ntsysv-1.3.49.3-2.el6_4.1.x86_64
sysvinit-tools-2.87-5.dsf.el6.x86_64
[root@mgmt3 ~]# rpm -qa | grep upstart
upstart-0.6.5-12.el6_4.1.x86_64
[root@mgmt3 ~]# service sssd status
sssd (pid  8006) is running...
[root@mgmt3 ~]# service sssd restart
Stopping sssd: [  OK  ]
[  OK  ] sssd: [  OK  ]
[root@mgmt3 ~]# service sssd stop
Stopping sssd: [  OK  ]
[root@mgmt3 ~]# service sssd restart
Stopping sssd: cat: /var/run/sssd.pid: No such file or directory
[FAILED]
[  OK  ] sssd: [  OK  ]
[root@mgmt3 ~]#

Comment 5 Jakub Hrozek 2014-03-20 19:41:55 UTC
Fixed upstream:
    master: 636caee5776fb062fde39bc761df142005dcb589
    sssd-1-11: d4ebaeb010645cb974aff21f00b8132ae5f2d85d

Comment 7 Amith 2014-06-26 09:06:16 UTC
Verified the bz on SSSD Version : sssd-1.11.6-1.el6.x86_64

Steps followed during verification -

# service sssd restart
Stopping sssd: [  OK  ]
Starting sssd: [  OK  ]

# rpm -q sssd
sssd-1.11.6-1.el6.x86_64

Comment 8 errata-xmlrpc 2014-10-14 04:48:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1375.html


Note You need to log in before you can comment on or make changes to this bug.