Bug 107405 - src rpms not download (404 - Page not found)
src rpms not download (404 - Page not found)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-17 15:41 EDT by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 14:28:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-10-17 15:41:49 EDT
Description of problem:

I selected the option to download the src rpms when I downloaded updates.  This
is using the new yum/rawhide interface for test3.

Instead of the src package being downloaded, I get a 404 message ... page not found.

I suspect the structure of the directory tree differs between rawhide and the
"rhn stucture" up2date normally expects.
Comment 1 Paul Nasrat 2003-10-23 06:14:22 EDT
Steps to reproduce:

1) Use a yum repository with SRMS not directly under yum root.
2) up2date --get-source foo
3) file /var/spool/up2date/foo-0.1-1.noarch.rpm reveals ASCII file long lines,
which is the 404 page

This is as up2date isn't using the path hints in header.src.info which is
generated by yum-arch -s
Comment 2 Paul Nasrat 2003-10-23 06:19:12 EDT
In addition this seems to be due to to http://ftp.redhat.com using a 302 to
direct to the error page and there not being a 404 in the HTTP header:

To reproduce lynx --mime_header
http://ftp.redhat.com/pub/redhat/linux/foo/foo-0.1-1.src.rpm | head

Other mirrors get an I/O Error as expected 
Comment 3 Gene Czarcinski 2003-10-27 14:28:17 EST
works now

Note You need to log in before you can comment on or make changes to this bug.