Bug 10741 - Signal 11 on upgrade 6.1 --> 6.2
Signal 11 on upgrade 6.1 --> 6.2
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Depends On:
  Show dependency treegraph
Reported: 2000-04-11 22:41 EDT by eschmenk
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-04-12 07:23:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description eschmenk 2000-04-11 22:41:32 EDT
I am getting a Signal 11 crash whenever I try to run a hard disk upgrade.
It appears to occur when the stage 2 image is loading.

Previously, when running 6.1, I had my harddisk partitioned as follows
hda1:  FAT16
hda5:  FAT16
hda6:  FAT16
hda7:  Linux
hda8:  Linux swap
Linux (RedHat 6.1) ran fine then.

Then I converted hda1 to FAT32 (using the Win98 utility).  Linux (6.1)
still ran OK, and I verified that I could still mount and read hda1.

Then I used FDISK to remove the hda5 partition (e.g., the first logical
drive in the extended partition).  LILO will no longer load Linux because
the kernel is no longer on hda7 (because that partition is hda6 now.)  I
hoped to be able to upgrade Linux to 6.2, and change the size of the hda1
partition while I was at it.  No dice, I get the signal 11 before I get
very far.

I haven't figured out how to use loadln to load Linux, which would allow
me to change LILO's configuration.  In any case, I don't think I should
have received the signal 11 during the upgrade.

Note:  I gave this a "low" priority because I really won't loose much by
doing a complete reinstall.  (I will report whether or not I run into the
same problem.)  This might be a higher priority for someone else, though...

Eric Schmenk
Comment 1 Jay Turner 2000-04-12 07:23:59 EDT
You are not going to be able to modify the size of partitions during an upgrade
of Red Hat Linux, although I am not sure whether that is causing the signal 11
or not.  There is a pretty good chance that the signal 11 is being caused by the
fact that the upgrade routine is trying to mount the partitions listed in
/etc/fstab and not being able to find those partitions because you have deleted
hda5.  This would certainly lead to a problem, as the upgrade routine is trying
to bail out before doing damage to the underlying filesystem.

There are a couple of ways that you can go with this.  You can either try to use
the rescue mode functionality of Red Hat Linux 6.2 to correct the problems in
your /etc/fstab as well as /etc/lilo.conf and get the 6.1 system back up and
running.  Once you have this, you should be able to upgrade without any
problems.  The other route that you might take is to just install 6.2 fresh on
the system.  If there is really not that much that you might lose, then this is
almost certainly the "easier" solution, as it requires the leasst amount of
Comment 2 eschmenk 2000-04-12 11:25:59 EDT
Correction:  The Signal 11 occured immediately after the "Finding Packages to
Upgrade" message popped up.  This is a couple of steps later than I reported.

I attempted to do a complete (fresh) install.  Disk Druid reported the following

HDA1   Win98 FAT32
HDA6   FAT16
HDA7   Linux
HDA8   Linux Swap

Note the gap in the partition numbering.  Apparently, Disk Druid checks the
/etc/fstab file also?  Disk Druid would not let me change the size of HDA1
(which I wanted to remain a Win98 FAT partition), so I exited without saving any
changes to the partition table.  I then tried to run FDISK (RedHat's version),
which promply crashed or locked up -- I can't remember which.

So, I went ahead and recreated the HDA5 partition using fdisk (Win98 version --
which is also what I used to delete the partition in the first place), and
formatted it using the Win98 Format command.  Then the upgrade to 6.2 went OK.

So far, the only problem I have noticed is that LILO seems to be ignoring
whatever configuration information I specify using linuxconf.  I assume this has
been reported as a bug elsewhere.

Personally, I would prefer that this bug report be concidered as an
enhancement.  I think the upgrade should fail more gracefully if there is a
problem between the /etc/fstab file and the actual hard drive partitions.  Why
not print out the /etc/fstab file, at least?


Note You need to log in before you can comment on or make changes to this bug.