Bug 1074122 - libftdi udev rules should use uaccess rather than non-existent plugdev group
libftdi udev rules should use uaccess rather than non-existent plugdev group
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libftdi (Show other bugs)
20
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lucian Langa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-07 21:01 EST by Eric Smith
Modified: 2014-07-10 11:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-24 11:24:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed replacement for libftdi udev rules (277 bytes, text/plain)
2014-03-07 21:01 EST, Eric Smith
no flags Details

  None (edit)
Description Eric Smith 2014-03-07 21:01:29 EST
Created attachment 872077 [details]
proposed replacement for libftdi udev rules

Description of problem:

libftdi provides /etc/udev/rules.d/99-libftdi.rules, which doesn't work as intended on recent Fedora releases (and probably EPEL7):

1)  The rules use GROUP="plugdev", but the plugdev group no longer exists.  (Regression from fix of bug #517773?)  That should be replaced with TAG+="uaccess"

2)  The rules file shouldn't be in /etc/udev/rules.d, which is for user-added rules.  It should be in /usr/lib/udev/rules.d

3)  The numeric portion of the rules file name needs to be less than 70, so it runs before /lib/udev/rules.d/70-uaccess.rules

I recommend replacing the existing file with the attached file as /lib/udev/rules.d/69-libftdi.rules.  (That will also resolve bug #1015289.)
Comment 1 Peter Robinson 2014-03-24 11:24:35 EDT
This will be fixed in 1.1 (committed to git now) but the new version will need some coordination with the dependent packages

Note You need to log in before you can comment on or make changes to this bug.