Bug 10742 - mouse cursor does weird things with mach64 and xboing
mouse cursor does weird things with mach64 and xboing
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-11 23:42 EDT by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-11 23:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2000-04-11 23:42:42 EDT
I have installed:

XFree86-100dpi-fonts-3.3.6-20
XFree86-3.3.6-20
XFree86-75dpi-fonts-3.3.6-20
XFree86-Mach64-3.3.6-20
XFree86-Xvfb-3.3.6-20
XFree86-devel-3.3.6-20
XFree86-doc-3.3.6-20
XFree86-libs-3.3.6-20
XFree86-xfs-3.3.6-20
xboing-2.4-10

My xinit output is:
XFree86 Version 3.3.6 / X Window System
(protocol Version 11, revision 0, vendor release 6300)
Release Date: January 8 2000
	If the server is older than 6-12 months, or if your card is newer
	than the above date, look for a newer version before reporting
	problems.  (see http://www.XFree86.Org/FAQ)
Operating System: Linux 2.2.5-22smp i686 [ELF]
Configured drivers:
  Mach64: accelerated server for ATI Mach64 graphics adaptors (Patchlevel
1)
(using VT number 7)

XF86Config: /usr/X11R6/lib/X11/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc104"
(**) XKB: layout: "en_US"
(**) Mouse: type: PS/2, device: /dev/mouse, buttons: 3
(**) Mach64: Graphics device ID: "3D Rage Pro AGP 1X/2X"
(**) Mach64: Monitor ID: "CTX 1785GM"
(**) FontPath set to "unix/:-1"
(--) Mach64: PCI: Mach64 RagePro rev 92, Aperture @ 0xfd000000, Registers @
0xfe6ff000, Block I/O @ 0xd800
(--) Mach64: PCI (92) and CONFIG_CHIP_ID (124) don't agree on ChipRev,
	using PCI value
(--) Mach64: Card type: AGP
(--) Mach64: Memory type: SDRAM (4)
(--) Mach64: Clock type: Internal
(--) Mach64: Maximum allowed dot-clock: 230.000 MHz
(**) Mach64: Mode "1280x1024": mode clock =  80.000
(--) Mach64: Virtual resolution: 1280x1024
(**) Mach64: Video RAM: 8192k
(**) Mach64: Using software cursor
(--) Mach64: Using 16 MB aperture @ 0xfd000000
(--) Mach64: Using 4 KB register aperture @ 0xfe6ff000
(--) Mach64: Ramdac is Internal
(--) Mach64: Ramdac speed: 230 MHz
(**) Mach64: Color weight: 565
(--) Mach64: Pixmap cache: 2 256x256 slots, 8 128x128 slots, 32 64x64 slots
(--) Mach64: Font cache: 16 fonts

When I run "xboing" and move the mouse over the xboing window, the cursor
is supposed to disappear; instead, I get a weird streak, about fifty pixels
wide, from where the cursor is down to the bottom of the screen.

This goes away when I enable the "sw_cursor" option in XF86Config.
Comment 1 Preston Brown 2000-08-29 14:23:32 EDT
because this only happens sometimes, and the hardware cursor is much faster, we
have not turned on the sw_cursor by default.  However, if you experience
problems such as this, we have been recommending turning on the software cursor.

Note You need to log in before you can comment on or make changes to this bug.