Bug 1074220 - localhost systemd: Unit systemd-logind.service entered failed state
Summary: localhost systemd: Unit systemd-logind.service entered failed state
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-09 03:16 UTC by Peter H. Jones
Modified: 2014-07-20 21:02 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-28 13:50:20 UTC


Attachments (Terms of Use)
/var/log/messages (146.27 KB, text/plain)
2014-03-09 03:16 UTC, Peter H. Jones
no flags Details

Description Peter H. Jones 2014-03-09 03:16:12 UTC
Created attachment 872332 [details]
/var/log/messages

Description of problem:
After booting to mode 3, can't use sddm to start graphics mode.

Version-Release number of selected component (if applicable):
util-linux-2.24.1-2.fc21.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Boot Fedora-Live-Jam-KDE-x86_64-rawhide-20140308.iso
2. Select Troubleshooting, use TAB to edit Boot with basic graphics to remove quiet, threadirqs and rggb and add 3
3. When boot prompt appears, log in as root.

Actual results:
/var/log contains logind error messages

Expected results:
No errors

Additional info:
If I try to use sddm (in VT2), the system tries to start a screen, but gets very sluggish and does I/O constantly on the DVD. The top command shows most time is spent in processes loop3 and ehci/irq17.

grep -n /var/log/messages (attached) contains the following lines of interest:
"1418:Mar  8 16:32:50 localhost systemd-logind: Failed to add match for NameOwnerChanged: Connection timed out
1419:Mar  8 16:32:50 localhost systemd-logind: Failed to fully start up daemon: Connection timed out
1438:Mar  8 16:32:54 localhost systemd: systemd-logind.service: main process exited, code=exited, status=1/FAILURE
1439:Mar  8 16:32:54 localhost systemd: Failed to start Login Service.
1440:Mar  8 16:32:54 localhost systemd: Unit systemd-logind.service entered failed state.
1444:Mar  8 16:32:54 localhost systemd: systemd-logind.service has no holdoff time, scheduling restart."

Comment 1 Zbigniew Jędrzejewski-Szmek 2014-03-10 14:52:47 UTC
What systemd package version? If it is less than v210-15, can you first 'yum install systemd' to get the latest version, and then 'systemctl restart systemd-logind'. Does is still happen with those updates?

Comment 2 Peter H. Jones 2014-03-10 18:14:01 UTC
It was systemd-210-7.fc21.x86_64, and unchanged in Fedora-Live-Jam-KDE-x86_64-rawhide-20140309.iso. Since this is happening on a 1G machine, I tried noswap, thinking I might be having a page thrashing problem. The "ehci" messages no longer appeared in the output of the "top" command, and only the "loop3" command showed significant activity.

Did you mean v208-15 instead of vt210-15? The latest builds of I see on koji are:
"systemd-210-7.fc21	karsten	2014-03-07 16:13:02	complete
systemd-210-6.fc21	karsten	2014-03-07 14:30:31	complete
systemd-210-5.fc21	zbyszek	2014-03-07 06:21:04	complete
systemd-208-15.fc20	zbyszek	2014-03-05 06:57:45	complete
systemd-210-3.fc21	zbyszek	2014-03-01 13:39:39	complete"

Comment 3 Zbigniew Jędrzejewski-Szmek 2014-03-11 00:10:32 UTC
Hm, is this ISO available for download somewhere?

Comment 5 Zbigniew Jędrzejewski-Szmek 2014-06-23 04:54:29 UTC
Is this still a problem?

I tried with Fedora-Live-Jam-KDE-x86_64-rawhide-20140622.iso following your instructions, and things generally seem to work. I see some issue with systemd-journald-dev-log.socket, but that seems unrelated.

Comment 6 Zbigniew Jędrzejewski-Szmek 2014-06-23 05:01:25 UTC
systemd-journal-dev-log.socket is #1112061.

Comment 7 Peter H. Jones 2014-06-28 04:59:57 UTC
Fedora-Live-Jam-KDE-x86_64-rawhide-20140627.iso works fine.

Comment 8 Zbigniew Jędrzejewski-Szmek 2014-06-28 13:50:20 UTC
I'll close this now then. Please reopen if the issue resurfaces.

Comment 9 poma 2014-07-20 21:02:46 UTC
systemd-logind.service entered failed state - has no holdoff time - i686
https://bugzilla.redhat.com/show_bug.cgi?id=1121419


Note You need to log in before you can comment on or make changes to this bug.