Bug 107423 - up2date tui update aborts on unsigned packages
Summary: up2date tui update aborts on unsigned packages
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-17 20:55 UTC by Fred New
Modified: 2007-04-18 16:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-04 20:38:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fred New 2003-10-17 20:55:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014

Description of problem:
After downloading a package to install, the tui up2date will abort if the
package being installed isn't signed; whereas, the gui up2date will ask if you
want to install the package anyway.

Version-Release number of selected component (if applicable):
up2date-4.1.7-1

How reproducible:
Always

Steps to Reproduce:
1.  Start gnome terminal.
2.  su -
3.  up2date -u tcl  (The tcl package doesn't "have a GPG signature".)
    

Actual Results:  Fetching package list for channel: rawhide...
.
<much removed>
.
tcl-8.3.5-93.i386.rpm:      ########################## Done.
The package tcl-8.3.5-93 is not signed with a GPG signature.  Aborting...
Package tcl-8.3.5-93 does not have a GPG signature.
 Aborting...
#

Expected Results:  I would expect the tui up2date to react the same as the gui
up2date and ask me if I would like to continue.  (It would also be nice if the
message also told me "sha1 md5 OK" like rpm -K does.)

Additional info:

Comment 1 Fred New 2003-10-19 14:11:10 UTC
Okay, I can see how you can get around this problem by using the --nosig
parameter.  I should have done a little more homework be opening this bug.  I'll
leave this open as a possible enhancement, though.

Comment 2 Adrian Likins 2003-11-04 20:38:25 UTC
closed as notabug, because the cmdline version is designed to be
as non-interactive as possible, and prompting for this would
run counter to that. 


Note You need to log in before you can comment on or make changes to this bug.