Bug 107426 - radeon driver + xfree freezing
radeon driver + xfree freezing
Status: CLOSED DUPLICATE of bug 78616
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
athlon Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-17 17:12 EDT by Tamas Sashalmi
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-18 13:53:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
var log file (80.40 KB, text/plain)
2003-10-17 17:25 EDT, Tamas Sashalmi
no flags Details

  None (edit)
Description Tamas Sashalmi 2003-10-17 17:12:46 EDT
Description of problem:
My system (AMD SMP (MPX)) hangs after boot with the following message:
 
[fglrx:firegl_lock_free] *ERROR* lock was not held by 1! (*lock=0x00000000)
[fglrx:firegl_unlock] *ERROR* firegl_lock_free failed!
 
fglrx is the ATI's official driver.
Everything was ok before the rawhide update of kernel and Xfree!
 kernel  2.4.22-1.2096.nptlsmp


Version-Release number of selected component (if applicable):
kernel  2.4.22-1.2096.nptlsmp
XFree86 Version 4.3.0 (Fedora Core 1: 4.3.0-40)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.21-2.ELsmp i686 [ELF]
Build Date: 15 October 2003
Build Host: daffy.perf.redhat.com



How reproducible:install ati driver (new) and rawhide (that's it)


Steps to Reproduce:
1.
2.
3.
    
Actual results:
freeze

Expected results:


Additional info:
the xfree try open the display twice, why? bad initialization? but the second  
kill the x11. older version is working fine.

I did not cut the message file so today is 17th of October...
Comment 1 Tamas Sashalmi 2003-10-17 17:25:10 EDT
Created attachment 95276 [details]
var log file
Comment 2 Mike A. Harris 2003-10-18 01:52:52 EDT
You'll have to seek support from ATI for this issue.  Red Hat does not provide
nor support binary only kernel modules and drivers.



*** This bug has been marked as a duplicate of 78616 ***
Comment 3 Tamas Sashalmi 2003-10-18 13:53:06 EDT
The new kernel + rawhide upgrade solved the problem.
So this bug wasn't related to ATI's binary.

Tamas
Comment 4 Mike A. Harris 2003-10-19 14:42:59 EDT
It may or may not have been, however binary 3rd party modules are still
unsupported by Red Hat either way wether the problems experienced are in
the binary modules or in the kernel itself.  They have our source code but
we don't have theirs, so we can't even investigate such matters to even
determine where the problem might exist, and 99% of the time, the problem
is in the binary only kernel blob.

Nonetheless, I'm happy to see it works for you now, thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.