This service will be undergoing disruptive maintenance at 7:00PM UTC, 2020-01-18. It is expected to last approximately one hour.
Bug 1074260 - racoon2 unresolved dependencies on epel6
Summary: racoon2 unresolved dependencies on epel6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: racoon2
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-09 10:00 UTC by Tuomo Soini
Modified: 2014-03-31 18:25 UTC (History)
2 users (show)

Fixed In Version: racoon2-20100526a-28.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 18:25:10 UTC


Attachments (Terms of Use)

Description Tuomo Soini 2014-03-09 10:00:04 UTC
Description of problem:

package: racoon2-20100526a-27.el6.x86_64 from epel-testing
  unresolved deps: 
     perl-Getopt-Simple

perl-Getopt-Simple is not available on epel6.

Comment 1 Pavel Šimerda (pavlix) 2014-03-13 10:16:35 UTC
Jan Klepek is taking care of this in bug #1073861. Thanks for reporting.

*** This bug has been marked as a duplicate of bug 1073861 ***

Comment 2 Jan Klepek 2014-03-13 10:32:04 UTC
Pavel, this is not duplicate of bug 1073861.

Bug 1073861 is for EPEL7 where this one is for EPEL 6.
There are no requests for EPEL6 branch of perl-Getopt-Simple.

Comment 3 Pavel Šimerda (pavlix) 2014-03-13 11:12:36 UTC
Aha. By the way, I just received a patch to actually avoid that dependency. If you don't want to add the package to el6 for other reasons, you can just reassign the bug to myself and I'll handle it using the submitted patch.

Comment 4 Jan Klepek 2014-03-13 12:13:26 UTC
well, will this patch also remove dependency for epel7?
Basically it is up to you which way you want to go. If needed, i can create branch for EL6 if you would like to (just please raise a ticket for that, so it does not slip out from my mind).

Comment 5 Pavel Šimerda (pavlix) 2014-03-14 15:21:57 UTC
Yes, it will be used for all fedora and epel versions. Look for the recent racoon2 updates in koji/bodhi and feel free to close any related bugs as WONTFIX or assign them to me (as appropriate). I definitely prefer less dependencies in this case.

The patch was proposed here:

https://bugzilla.redhat.com/show_bug.cgi?id=995743#c7

Comment 6 Fedora Update System 2014-03-14 15:23:02 UTC
racoon2-20100526a-28.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0771/racoon2-20100526a-28.el6

Comment 7 Fedora Update System 2014-03-15 19:48:39 UTC
Package racoon2-20100526a-28.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing racoon2-20100526a-28.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0771/racoon2-20100526a-28.el6
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-03-31 18:25:10 UTC
racoon2-20100526a-28.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.