Bug 1074286 - sugar-toolkit installs macros files to /etc/rpm
Summary: sugar-toolkit installs macros files to /etc/rpm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar-toolkit
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL: https://lists.fedoraproject.org/piper...
Whiteboard:
Depends On:
Blocks: 1074261 1107384 1107385 1107386 1107387 1107388 1107389 1107390 1107391 1107392 1107393 1107394 1107395 1107396 1107400 1107401 1107404 1107405 1107406 1107407 1107408 1107409 1107410 1107411 1107412 1107413 1107414 1107415
TreeView+ depends on / blocked
 
Reported: 2014-03-09 10:53 UTC by Ville Skyttä
Modified: 2014-06-13 13:48 UTC (History)
5 users (show)

Fixed In Version: sugar-toolkit-0.98.1-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 13:48:21 UTC
Type: ---


Attachments (Terms of Use)
Patch for rawhide (1.52 KB, patch)
2014-06-13 00:22 UTC, Yaakov Selkowitz
no flags Details | Diff

Description Ville Skyttä 2014-03-09 10:53:33 UTC
The proper location for rpm macros files in rpm >= 4.11 is
%{_rpmconfigdir}/macros.d, please move them there from /etc/rpm.

If this package's specfile targets Fedora and EL >= 7 only, the
location for macro files can be simply changed from /etc/rpm to
%{_rpmconfigdir}/macros.d. If it is intended to work on EL 5 and/or 6
as well, you can define a macros dir for example as follows (all on
one line) and install the macros to %{macrosdir}:

%global macrosdir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)

Comment 1 Yaakov Selkowitz 2014-06-13 00:22:51 UTC
Created attachment 908337 [details]
Patch for rawhide

Actually, -3 didn't quite fix this.  %{_rpmconfigdir}/macros.d is a _directory_ in which all macros.* files must now be installed.  Patch for rawhide attached.

Comment 2 Yaakov Selkowitz 2014-06-13 01:44:57 UTC
Reopening.

Comment 3 Yaakov Selkowitz 2014-06-13 01:53:35 UTC
This is the cause of the FTBFSs in the sugar activities; the only change necessary should be this one to sugar-toolkit itself.


Note You need to log in before you can comment on or make changes to this bug.