Bug 1074298 - VMs are paused after migration from 3.2 to 3.3 hypervisor
Summary: VMs are paused after migration from 3.2 to 3.3 hypervisor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.3.2
Assignee: Federico Simoncelli
QA Contact: Elad
URL:
Whiteboard: storage
Depends On: 1066445
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-09 13:27 UTC by rhev-integ
Modified: 2019-04-28 09:26 UTC (History)
23 users (show)

Fixed In Version: is35
Doc Type: Bug Fix
Doc Text:
Virtual machines are no longer paused after migrations from 3.2 hypervisors to 3.3 hypervisors.
Clone Of: 1066445
Environment:
Last Closed: 2014-04-09 17:42:17 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 727423 None None None Never
Red Hat Knowledge Base (Solution) 727433 None None None Never
Red Hat Product Errata RHBA-2014:0392 normal SHIPPED_LIVE vdsm 3.3.2 bug fix update 2014-04-09 21:40:59 UTC

Comment 1 Elad 2014-03-30 12:56:45 UTC
Check on RHEVM - 3.3.2 (IS35.1)
Migration ended successfully* between the following vdsm versions:

3.2 - 3.3.0  
3.3.0 - 3.2   *(with errors - look below)
3.2 - 3.3.0-3  
3.3.0 - 3.2   *(with errors - look below)
3.3.0 - 3.3.0-3 
3.3.0-3 - 3.3.0








* Migration between vdsm 3.3.0 to vdsm 3.2 succeeded, but the following errors appeared in vdsm.log (full vdsm.log is attached): 

libvirtEventLoop::ERROR::2014-03-30 15:34:42,038::libvirtconnection::91::vds::(__eventCallback) Error running VM callback
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 67, in __eventCallback
    v._onLibvirtLifecycleEvent(event, detail, None)
  File "/usr/share/vdsm/libvirtvm.py", line 3033, in _onLibvirtLifecycleEvent
    hooks.after_vm_cont(self._dom.XMLDesc(0), self.conf)
AttributeError: 'NoneType' object has no attribute 'XMLDesc'
libvirtEventLoop::DEBUG::2014-03-30 15:34:42,111::libvirtvm::3003::vm.Vm::(_onLibvirtLifecycleEvent) vmId=`449e7bb9-070f-43e0-9ae8-a9d344dadbf6`::event Resumed detail 1 opaque None
Thread-400::DEBUG::2014-03-30 15:34:42,194::utils::346::vm.Vm::(start) vmId=`449e7bb9-070f-43e0-9ae8-a9d344dadbf6`::Start statistics collection
Thread-404::DEBUG::2014-03-30 15:34:42,194::utils::375::vm.Vm::(run) vmId=`449e7bb9-070f-43e0-9ae8-a9d344dadbf6`::Stats thread started
Thread-404::DEBUG::2014-03-30 15:34:42,196::task::568::TaskManager.Task::(_updateState) Task=`77048e13-41f3-4c00-b8fc-6e01fa80d862`::moving from state init -> state preparing
Thread-404::INFO::2014-03-30 15:34:42,196::logUtils::37::dispatcher::(wrapper) Run and protect: getVolumeSize(sdUUID='65f5eb98-b119-464f-a71e-6902957c5c4e', spUUID='9cf4d589-6cb3-46ba-847f-ba074fdb4ae8', imgUUID='aa19aba0-4ae3-4096-9b72-70a7d53ff045', volUUID='b149b182-e839-4843-b685-086b7c9518a2', options=None)
MainProcess|Thread-400::ERROR::2014-03-30 15:34:42,196::supervdsmServer::81::SuperVdsm.ServerCallback::(wrapper) Error in prepareVmChannel
Traceback (most recent call last):
  File "/usr/share/vdsm/supervdsmServer.py", line 79, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/vdsm/supervdsmServer.py", line 159, in prepareVmChannel
    mode = os.stat(socketFile).st_mode | stat.S_IWGRP
OSError: [Errno 2] No such file or directory: '/var/lib/libvirt/qemu/channels/32-2.com.redhat.rhevm.vdsm'
Thread-404::DEBUG::2014-03-30 15:34:42,199::fileVolume::574::Storage.Volume::(validateVolumePath) validate path for b149b182-e839-4843-b685-086b7c9518a2
Thread-404::INFO::2014-03-30 15:34:42,200::logUtils::39::dispatcher::(wrapper) Run and protect: getVolumeSize, Return response: {'truesize': '0', 'apparentsize': '2147483648'}
Thread-404::DEBUG::2014-03-30 15:34:42,200::task::1151::TaskManager.Task::(prepare) Task=`77048e13-41f3-4c00-b8fc-6e01fa80d862`::finished: {'truesize': '0', 'apparentsize': '2147483648'}
Thread-404::DEBUG::2014-03-30 15:34:42,200::task::568::TaskManager.Task::(_updateState) Task=`77048e13-41f3-4c00-b8fc-6e01fa80d862`::moving from state preparing -> state finished
Thread-404::DEBUG::2014-03-30 15:34:42,201::resourceManager::809::ResourceManager.Owner::(releaseAll) Owner.releaseAll requests {} resources {}
Thread-404::DEBUG::2014-03-30 15:34:42,201::resourceManager::844::ResourceManager.Owner::(cancelAll) Owner.cancelAll requests {}
Thread-404::DEBUG::2014-03-30 15:34:42,201::task::957::TaskManager.Task::(_decref) Task=`77048e13-41f3-4c00-b8fc-6e01fa80d862`::ref 0 aborting False
Thread-400::ERROR::2014-03-30 15:34:42,197::guestIF::103::vm.Vm::(__init__) vmId=`449e7bb9-070f-43e0-9ae8-a9d344dadbf6`::Failed to prepare vmchannel
Traceback (most recent call last):
  File "/usr/share/vdsm/guestIF.py", line 101, in __init__
    self._prepare_socket()
  File "/usr/share/vdsm/guestIF.py", line 113, in _prepare_socket
    supervdsm.getProxy().prepareVmChannel(self._socketName)
  File "/usr/share/vdsm/supervdsm.py", line 76, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 67, in <lambda>
    **kwargs)
  File "<string>", line 2, in prepareVmChannel
  File "/usr/lib64/python2.6/multiprocessing/managers.py", line 740, in _callmethod
    raise convert_to_error(kind, result)
OSError: [Errno 2] No such file or directory: '/var/lib/libvirt/qemu/channels/32-2.com.redhat.rhevm.vdsm'



Moving to VERIFIED, Federico, can you please look at the errors?

Comment 2 Zac Dover 2014-04-03 02:54:33 UTC
This bug is currently attached to errata RHBA-2014:17276. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.

* Consequence: What happens when the bug presents.

* Fix: What was done to fix the bug.

* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks in advance.

Comment 4 errata-xmlrpc 2014-04-09 17:42:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0392.html


Note You need to log in before you can comment on or make changes to this bug.