Bug 107445 - Official NVidia GeForce drivers experience heavy OpenGL issues on XFree86 > 4.3.0-36
Official NVidia GeForce drivers experience heavy OpenGL issues on XFree86 > 4...
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-18 06:11 EDT by Jan Schiefer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Schiefer 2003-10-18 06:11:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030927

Description of problem:
When you install XFree-4.3.0-36 of XFree-4.3.0-40 and you use the official
NVidia Geforce drivers from www.nvidia.com experience heavy OpenGL issues like
missing sufaces, a massive slowdown, heavy shadow issues...

I had to downgrade to XFree86-4.3.0-2 to solve this problem.

-Kernel 2.4.22 (happens on 2.4.20 and 2.4.21 too) 

Hardware: 
-NVidia GeForce 2 (Elsa Erazor X II)/ NVidia GeForce 1 (old Elsa Erazor X)
-MSI K7N2 Delta-T nforce2 Mainboard
...

Version-Release number of selected component (if applicable):
XFree86-4.3.0-36

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to XFree86-4.3.0-36 or XFree-4.3.0-40
2. Install the NVidia drivers from nvidia.com and make the changes in XF86Config
3. Start an OpenGL-Game like Enemy-Territory, Tux Racer, ePSXe...
    

Actual Results:  Heavy OpenGL issues like missing sufaces, a massive slowdown,
heavy shadow issues...

Expected Results:  Normal, fast, OpenGL display.

Additional info:

Is it a patch bug?
I mean Redhat hass applied several patches to the  XFree86 package...
Comment 1 Mike A. Harris 2003-10-18 06:32:42 EDT
Nvidia's proprietary drivers include:

- Nvidia's proprietary 2D XFree86 video driver
- Nvidia's proprietary libGL OpenGL implementation
- Nvidia's proprietary 3D driver
- Nvidia's proprietary kernel module and agpgart implementation

Red Hat does not ship nor support Nvidia's proprietary drivers.  Please
contact the vendor who supplied these drivers to you for technical support.

This is not a Red Hat induced problem.

*** This bug has been marked as a duplicate of 73733 ***
Comment 2 Jan Schiefer 2003-10-18 08:20:59 EDT
Sorry.
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.