Bug 1074585 - [RFE] 'dnf builddep' should be able to take just the package name as argument rather than SPEC or SRPM
[RFE] 'dnf builddep' should be able to take just the package name as argument...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
rawhide
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Michael Mráka
Fedora Extras Quality Assurance
:
: 1109811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-10 11:15 EDT by Kashyap Chamarthy
Modified: 2015-05-08 03:27 EDT (History)
9 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.7-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1265622 (view as bug list)
Environment:
Last Closed: 2015-05-08 03:27:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kashyap Chamarthy 2014-03-10 11:15:59 EDT
Currently, running

  $ dnf builddep

needs a SPEC file or an SRPM to be passed to it. However, in yum, you could just pass the package name (like yum-builddep libvirt) which is more useful and simpler.

'dnf builddep' would be more useful if it can just take the package name to build dependencies.


Related bug #905697 -- [rfe] [plugin] yum-builddep like functionality through dnf
Comment 1 Ales Kozumplik 2014-03-10 11:24:11 EDT
As James explained: this needs to be implemented by enabling the source repos and looking up the requires (=BuildRequires) there.

Giving this a lower priority now.
Comment 2 Ales Kozumplik 2014-06-23 03:43:37 EDT
*** Bug 1109811 has been marked as a duplicate of this bug. ***
Comment 3 Ales Kozumplik 2014-06-23 03:45:53 EDT
An important insight into this is given by Panu in bug 905697 comment 21.
Comment 4 Petr Spacek 2014-12-06 10:52:01 EST
Note: Ability to use SPEC file when you are trying to build package from older/newer Fedora or something like that. Plase do not remove this ability.

I'm renaming this bug to make clear that plain package name should be only additional feature and not replacement for current behavior.
Comment 5 Michael Mráka 2015-04-24 07:16:27 EDT
Added to upstream in
https://github.com/rpm-software-management/dnf-plugins-core/pull/74
Comment 6 Fedora Update System 2015-05-02 09:49:28 EDT
dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22
Comment 7 Fedora Update System 2015-05-03 13:24:27 EDT
Package dnf-plugins-core-0.1.7-1.fc22, hawkey-0.5.5-1.fc22, dnf-1.0.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.7-1.fc22 hawkey-0.5.5-1.fc22 dnf-1.0.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7483/dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2015-05-08 03:27:02 EDT
dnf-plugins-core-0.1.7-1.fc22, hawkey-0.5.5-1.fc22, dnf-1.0.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.