Bug 10746 - /etc/crontab format
Summary: /etc/crontab format
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: crontabs (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-12 14:14 UTC by Michael Redinger
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 22:02:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Redinger 2000-04-12 14:14:28 UTC
Ok, maybe I'm missing something, but as I do not find any other
documentation, I suppose this is a bug:

After installation, there is no root crontab file, but there's a file
/etc/crontab. However, you must not install it using crontab /etc/crontab
because this file is not in cron format. It reads something like this:
01 * * * * root run-parts /etc/cron.hourly
However, for vixie-cron, this should read:
01 * * * * root run-parts /etc/cron.hourly


So, actually, if I am right, this are two bugs:

- the crontab should be installed per default (otherwise important
  scripts from /etc/cron.* will simply never run

- the format of /etc/crontab is wrong

Comment 1 Bill Nottingham 2000-04-12 15:33:59 UTC
/etc/crontab is read automatically by the cron daemon.
See the cron(8) man page.


Note You need to log in before you can comment on or make changes to this bug.