Bug 107470 - IDE/SATA and grub all messed up on Dell PE400SC
IDE/SATA and grub all messed up on Dell PE400SC
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-18 15:34 EDT by Jon Smirl
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-18 17:43:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Smirl 2003-10-18 15:34:05 EDT
The installer is completely broken on Dell PE400SC/ Dimension 8300 systems with
i875P based motherboard and mixed IDE/SATA drives. I finally got it to install
but it took me two days.

The basic problem seems to be what is drive 0 and 1. The bios and grub have them
backwards from each other.

For example in my system the installer wrote the grub MBR to one drive and /boot
to another. This results in getting GRUB->hang on the screen.

Once you figure out what is happening it is possible to fix everything by hand
editing the device.map, fstab, etc.

Dell PE400SC machine is $499. I'd recommend it as an excellent test platform for
875P and hyperthread CPU. Motherboard is OEM Intel.

Also, SMP kernel hangs at boot on same machine if SATA is enabled. I believe
this is because SATA IRQ is not enabled unless full APCI is turned on under SMP.
Comment 1 Jeremy Katz 2003-10-18 17:43:02 EDT
The installer provides an interface on the advanced boot loader screen to
reorder drives.  Unfortunately, on PC hardware there is no way to tell what the
order of drives according to the BIOS is.
Comment 2 Jon Smirl 2003-10-18 18:33:52 EDT
It's not a bug that installing Fedora CDs with default options on a common Dell
system results in an unbootable system? How many tech support calls is this
going to cause? 

Note You need to log in before you can comment on or make changes to this bug.