Bug 1074879 - iBus does not honor layout options (e.g. cz(qwerty))
Summary: iBus does not honor layout options (e.g. cz(qwerty))
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-11 07:46 UTC by Martin Sourada
Modified: 2014-04-15 15:42 UTC (History)
4 users (show)

Fixed In Version: ibus-1.5.6-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of: 760213
Environment:
Last Closed: 2014-04-07 03:23:05 UTC


Attachments (Terms of Use)

Description Martin Sourada 2014-03-11 07:46:46 UTC
+++ This bug was initially created as a clone of Bug #760213 +++

Description of problem:
I want to use multiple keyboard layouts: English/US, and Czech(qwerty) and Japanese (mozc). I have added the Japanese one to ibus, but there's no option for Czech(qwerty) and it does not pick up system defined layouts (via XFCE's Preferences -> Keyboard -> Layouts). This in Xfce. Last time this used to work was a few releases back, probably F17, sorry about reporting it so late. Happens both on upgraded installs (tested on i686) and fresh install where I even added the czech(qwerty) in anaconda (tested on x86_64).

Version-Release number of selected component (if applicable):
ibus-1.5.5-2.fc20.i686

How reproducible:
100 %

Steps to Reproduce:
1. Run an XFCE4 session
2. Run (main menu) -> Settings -> Keyboard
3. In Layout make sure there's English (US) and Czech with Czech (qwerty) variant.
4. Choose "Use iBus (recommended)" in (main menu)->Settings->Input Method Selector, then click on the "Preferences..." next to iBus. 
  
Actual results:
System layouts are present neither in config dialog nor ibus layout switcher, nor can czech(qwerty) be added.

Expected results:
Either pick up system layouts automagically or let the user pick up all variants of given national layout.


Additional info:
I want to use iBus because I occasionally need also Japanese input (with mozc engine) and I want to have only one way (one shortcut) to switch between all the different layouts/ims.

I don't think it is XFCE4 specific, but I currently don't have GNOME3 installed in order to verify this.

Comment 1 Martin Sourada 2014-03-11 07:48:05 UTC
And one additional note:
Bug 696481 might be related.

Comment 2 fujiwara 2014-03-12 02:22:52 UTC
ibus 1.5 limits the available keymaps.
If you add the following lines in /usr/share/ibus/component/simple.xml and restart ibus, cz(qwerty) will be available in ibus-setup.


                <engine>
                        <name>xkb:cz:qwerty:cze</name>
                        <language>cze</language>
                        <license>GPL</license>
                        <author>Peng Huang &lt;shawn.p.huang@gmail.com&gt;</author>
                        <layout>cz</layout>
                        <layout_variant>qwerty</layout_variant>
                        <longname>Czech (qwerty)</longname>
                        <description>Czech (qwerty)</description>
                        <icon>ibus-keyboard</icon>
                        <rank>99</rank>
                </engine>


I understood cz(qwerty) is popular now and I will fix this.

Comment 4 Jan "Yenya" Kasprzak 2014-03-18 08:09:59 UTC
Thanks for the fix. I have a higher-level question, though: is it wise to repeat only some of the keymaps defined in the XKB configuration in another configuration file? Why not offer them all by default? It looks like we are waiting for this bug to reappear, next time with another not so common keymap variant, which is nevertheless defined in the XKB config.

Comment 5 fujiwara 2014-03-19 02:48:13 UTC
(In reply to Jan "Yenya" Kasprzak from comment #4)
> Thanks for the fix. I have a higher-level question, though: is it wise to
> repeat only some of the keymaps defined in the XKB configuration in another
> configuration file? Why not offer them all by default? It looks like we are
> waiting for this bug to reappear, next time with another not so common
> keymap variant, which is nevertheless defined in the XKB config.

There are too many keymaps that we show on ibus-setup.
Currently we add keymaps upon the request if you really think some of keymaps should be shown by default.
It works on almost desktops that sysadmin edits the simple.xml by manual to add keymaps.

If the current process has a problem, we will discuss about it.

Comment 6 Fedora Update System 2014-03-28 14:26:51 UTC
ibus-1.5.6-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-1.5.6-2.fc19

Comment 7 Fedora Update System 2014-03-28 14:27:03 UTC
ibus-1.5.6-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-1.5.6-2.fc20

Comment 8 Fedora Update System 2014-03-30 06:06:53 UTC
Package ibus-1.5.6-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.5.6-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4486/ibus-1.5.6-2.fc19
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-04-07 03:23:05 UTC
ibus-1.5.6-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-04-15 15:42:37 UTC
ibus-1.5.6-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.