Bug 107490 - mkinitrd does not embed the right insmod
mkinitrd does not embed the right insmod
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-19 08:02 EDT by Francois-Xavier 'FiX' KOWALSKI
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 11:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Embed both old & new insmod (345 bytes, patch)
2003-10-19 08:04 EDT, Francois-Xavier 'FiX' KOWALSKI
no flags Details | Diff

  None (edit)
Description Francois-Xavier 'FiX' KOWALSKI 2003-10-19 08:02:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030730

Description of problem:
System config:
1. / on LVM1
2. /boot on ext3

mkinitrd does not produce a bootable system.  this affects both an upgrade from
rh8 to rh9 & a new kernel install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a new RedHat-packaged kernel
2. Reboot on the new kernel
3.
    

Actual Results:  Kernel Panic: no root found

Expected Results:  System should boot

Additional info:

When creating a new initrd, mkinitrd embeds insmod.static but not
insmod.static.old.  As a result, no module can be loaded at next boot time & I
end-up with a "Kernel Panic" because no root can be found.

This bug is of the "How could this ever work?" type.  It was already present on
RedHat Linux 8.  The patch applies to both rh9 & rh8.
Comment 1 Francois-Xavier 'FiX' KOWALSKI 2003-10-19 08:04:28 EDT
Created attachment 95294 [details]
Embed both old & new insmod
Comment 2 Jeremy Katz 2003-10-19 11:47:24 EDT
This is because you installed module-init-tools which move things around poorly
on the system.   If you want to use 2.4 and 2.[56] kernels, install the modutils
from rawhide which also includes the module-init-tools stuff but in a way that
doesn't break backwards compatibility.
Comment 3 Francois-Xavier 'FiX' KOWALSKI 2003-10-21 03:36:35 EDT
Uuh?

1. I do not play with 2.[56] kernels
2. I installed my initial rh8 from scratch (rh installed)
3. I upgraded from rh8 to rh9 booting from the rh9 cdrom

What is that bad in the above?  Shall I assume from now that Rawhide is the only
safe branch?
Comment 4 Jeremy Katz 2003-10-21 11:00:47 EDT
insmod.static.old only ever exists if you install the upstream module-init-tools
which is only required for the 2.6 kernel.  Otherwise, there is no
insmod.static.old to be concerned with.

And module-init-tools renaming binaries is *broken* and impossible for
distribution scripts to support.

Note You need to log in before you can comment on or make changes to this bug.