Bug 107496 - rfe: consider upgrading e1000 to 5.2.20-k1
Summary: rfe: consider upgrading e1000 to 5.2.20-k1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-19 13:18 UTC by Kaj J. Niemi
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-21 02:08:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
e1000 5.2.20 inserted into the kernel tree (216.42 KB, patch)
2003-11-17 16:05 UTC, Kaj J. Niemi
no flags Details | Diff
diff with spec file changes (1.27 KB, patch)
2003-11-17 16:06 UTC, Kaj J. Niemi
no flags Details | Diff

Description Kaj J. Niemi 2003-10-19 13:18:50 UTC
Description of problem:
Please consider upgrading current e1000 v2.1.13-k1 to the latest from Intel.

/* Change Log
 *
 * 5.2.20	9/30/03
 *   o Bug fix: SERDES devices might be connected to a back-plane
 *     switch that doesn't support auto-neg, so add the capability
 *     to force 1000/Full.
 *   o Bug fix: Flow control settings for hi/lo watermark didn't
 *     consider changes in the Rx FIFO size, which could occur with
 *     Jumbo Frames or with the reduced FIFO in 82547.
 *   o Better propagation of error codes. [Janice Girouard 
 *     (janiceg@us.ibm.com)].
 *   o Bug fix: hang under heavy Tx stress when running out of Tx
 *     descriptors; wasn't clearing context descriptor when backing
 *     out of send because of no-resource condition.
 *
 * 5.2.16	8/8/03
 *   o Added support for new controllers: 82545GM, 82546GB, 82541/7_B1
 *   o Bug fix: reset h/w before first EEPROM read because we don't know
 *     who may have been messing with the device before we got there.
 *     [Dave Johnson (ddj -a-t- cascv.brown.edu)]
 *   o Bug fix: read the correct work from EEPROM to detect programmed
 *     WoL settings.
 *   o Bug fix: TSO would hang if space left in FIFO was being miscalculated
 *     when mss dropped without a correspoding drop in the DMA buffer size.
 *   o ASF for Fiber nics isn't supported.
 *   o Bug fix: Workaround added for potential hang with 82544 running in
 *     PCI-X if send buffer terminates within an evenly-aligned dword.
 *   o Feature: Add support for ethtool flow control setting.
 *   o Feature: Add support for ethtool TSO setting.
 *   o Feature: Increase default Tx Descriptor count to 1024 for >= 82544.
 *   
 * 5.1.13	5/28/03
 */


Thanks :)

Comment 1 Kaj J. Niemi 2003-11-17 16:05:56 UTC
Created attachment 96017 [details]
e1000 5.2.20 inserted into the kernel tree

Diff from 2.4.22-1.2115.nptl to upgrade e1000 to 5.2.20

Comment 2 Kaj J. Niemi 2003-11-17 16:06:52 UTC
Created attachment 96018 [details]
diff with spec file changes

Diff from 2.4.22-1.2115.nptl kernel-2.4.spec

Comment 3 Kaj J. Niemi 2003-12-21 02:08:23 UTC
Guess this one is unnecessary as 2.6 comes with 5.2.20-k1 already.
Resolving as RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.