Bug 1074999 - Application disappears from Manage Deployments section of EAP console
Summary: Application disappears from Manage Deployments section of EAP console
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management
Version: 6.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER5
: EAP 6.3.0
Assignee: Emmanuel Hugonnet (ehsavoie)
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Keywords:
: 1040493 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-11 10:46 UTC by Tomas David
Modified: 2014-07-15 02:11 UTC (History)
5 users (show)

(edit)
In previous versions of JBoss EAP 6, the status of a deployment was not updated on the filesystem when the console was used.

As a consequence, using both the filesystem scanner and the console to manage the status of a deployment resulted in the scanner believing the deployment to be undeployed.

This release of the product enables the console and the filesystem scanner to share the status of the deployment and users can now use both administrative tools to manage deployments.
Clone Of:
(edit)
Last Closed: 2014-06-28 15:39:19 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-3198 Major Resolved Reenabling an application prevents it from deployement after a restart 2017-08-26 11:19 UTC
Red Hat Bugzilla 1092355 None None None Never
JBoss Issue Tracker WFLY-3305 Major Resolved :deploy after :undeploy is broken 2017-08-26 11:19 UTC

Internal Trackers: 1092355

Description Tomas David 2014-03-11 10:46:29 UTC
Description of problem:
Application disappears from Manage Deployments section of EAP console after reenabling the application and after server restart. 

Version-Release number of selected component (if applicable):
EAP 6.1.1.GA

How reproducible:
Always when application is disabled -> enabled -> and server is restarted.

Steps to Reproduce:
1. Unzip jboss-eap-6.1.1.zip. Create management user. Copy some Application.war into jboss-eap-6.1/standalone/deployments. Create file Application.war.dodeploy in the same folder.
2. Start standalone server.
3. Open EAP console -> Manage Deployments. Disable application. Enable application (After this Application.war.undeployed should be replaced with Application.war.deployed in jboss-eap-6.1/standalone/deployments folder).
4. Restart standalone server.
5. Open EAP console -> Manage Deployments.

Actual results:
Application disappears from Manage Deployments section of EAP console.
Application.war.undeployed file is present in jboss-eap-6.1/standalone/deployments folder.

Expected results:
Application is still visible in Manage Deployments section of EAP console.
Application.war.deployed file is present in jboss-eap-6.1/standalone/deployments folder.

Additional info:

Comment 1 Brian Stansberry 2014-03-11 14:01:44 UTC
My experience (with 6.2.0) is different from the description. After disabling and then re-enabling the application, I don't see Application.war.deployed; I still see Application.war.undeployed.

That explains why it doesn't get deployed after restart.

Comment 2 Tomas David 2014-03-11 14:21:06 UTC
I see also Application.war.undeployed after step 3. In brackets I described what I am expecting after step 3.

Comment 4 Emmanuel Hugonnet (ehsavoie) 2014-04-02 12:24:21 UTC
Upstream PR :  https://github.com/wildfly/wildfly/pull/6117
PR : https://github.com/jbossas/jboss-eap/pull/1179

Comment 6 Kabir Khan 2014-04-29 16:27:40 UTC
Setting this back to assigned since it caused https://bugzilla.redhat.com/show_bug.cgi?id=1092355 which was raised as a potential beta blocker. To get around this the commit for https://bugzilla.redhat.com/show_bug.cgi?id=1092355 was reverted on the 6.x branch and also in the 'special' branch used for ER3 containing just ER2 and beta blockers: https://github.com/jbossas/jboss-eap/tree/EAP_6.3.0.ER3-dev

Comment 7 Emmanuel Hugonnet (ehsavoie) 2014-05-07 12:49:38 UTC
Upstream PR : https://github.com/wildfly/wildfly/pull/6220
PR: https://github.com/jbossas/jboss-eap/pull/1309

Comment 8 Emmanuel Hugonnet (ehsavoie) 2014-05-07 12:55:53 UTC
*** Bug 1040493 has been marked as a duplicate of this bug. ***

Comment 9 Petr Kremensky 2014-06-19 08:15:17 UTC
Verified on EAP 6.3.0.ER7


Note You need to log in before you can comment on or make changes to this bug.