Bug 107505 - tripwire --check fails
Summary: tripwire --check fails
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tripwire   
(Show other bugs)
Version: 7.3
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-19 17:08 UTC by Need Real Name
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 00:49:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-10-19 17:08:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a)
Gecko/20030721

Description of problem:
tripwire fails during tripwire --check with a:

### Error: A bad index was encountered in file.

somewhere in the middle of checking.

I have done a clean install of tripwire and generated new database (--init) with
no error but I still get this when I go to check.

Any ideas what is causing this?

Version-Release number of selected component (if applicable):
tripwire-2.3.1-10

How reproducible:
Always

Steps to Reproduce:
1. install tripwire
2. twinstall
3. tripwire --init
4. tripwire --check
    

Actual Results:  Se above.

Additional info:

Comment 1 Need Real Name 2003-10-20 15:39:05 UTC
More info here.

This seems to happen across all redhat distros, not just 7.3.  I have also swapped out hard drives 
with no difference.  Right now, I suspect something in the motherboard/cpu combo or a (very) 
elusive bug in tripwire.

Linux installs and seems to run fine.  This is the only odd behavior that I have seen.  FYI, the 
motherboard is a SOYO K7VMP with an Athlon XP2500 cpu.  Anyone else have experience with this 
particular beast?

Comment 2 Need Real Name 2003-10-20 15:43:46 UTC
Oops.  I forgot to mention that this happens on a virgin 7.3 install as well as a virgin + updates 
install.

Comment 3 Michael Schwendt 2004-10-22 13:50:31 UTC
The error means that Tripwire's input serializer stumbled upon a fatal
data inconsistency. I've not seen anyone with such an error before,
and I doubt it is a general issue with Tripwire.

Comment 4 John Thacker 2006-04-22 00:49:39 UTC
Closing bug, since tripwire hasn't been shipped for so long, only in Legacy
releases.


Note You need to log in before you can comment on or make changes to this bug.