Bug 1075102 - Duplicated CD device when creating VMs from the blank template
Summary: Duplicated CD device when creating VMs from the blank template
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.4
Assignee: Tomas Jelinek
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks: 1118689 1154674
TreeView+ depends on / blocked
 
Reported: 2014-03-11 13:55 UTC by Vitor de Lima
Modified: 2014-10-20 13:31 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-24 08:08:51 UTC
oVirt Team: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25617 0 ovirt-engine-3.4 ABANDONED core, engine: Avoid creating the CD device multiple times Never
oVirt gerrit 25684 0 master MERGED core, engine: Avoid creating the CD device multiple times Never
oVirt gerrit 32929 0 ovirt-engine-3.4 MERGED core, engine: Avoid creating the CD device multiple times Never
oVirt gerrit 33885 0 ovirt-engine-3.5 MERGED core, engine: Avoid creating the CD device multiple times Never
oVirt gerrit 33886 0 ovirt-engine-3.5.0 MERGED core, engine: Avoid creating the CD device multiple times Never

Description Vitor de Lima 2014-03-11 13:55:47 UTC
Description of problem:
When creating a VM from the blank template, if there is more than one device attached to the blank template (in the vm_device table), the CD device is created multiple times.

Version-Release number of selected component (if applicable):
3.4rc2

How reproducible:
Sometimes

Steps to Reproduce:
1. Create a new VM from the blank template and attach an ISO to it
2. Run the VM

Actual results:
QEMU fails with a duplicated CD device in the same IDE address.

Expected results:
The VM should start.

Additional info:
I don't know how an extra device got into the blank template, please discuss in the attached gerrit change how to solve this issue.

Comment 1 Omer Frenkel 2014-03-12 09:20:19 UTC
i wonder how this happened, i could not reproduce this on master
what do you get if you run this in the db:
 select * from vm_device where vm_id = '00000000-0000-0000-0000-000000000000';

Comment 2 Vitor de Lima 2014-03-12 11:47:36 UTC
This query returns two devices: a cirrus video card and a sound card.

Comment 3 Sandro Bonazzola 2014-05-08 13:55:33 UTC
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.

Comment 4 Omer Frenkel 2014-09-15 11:02:55 UTC
moving back to post in order to get it to 3.4.4 as well

Comment 5 Sandro Bonazzola 2014-09-24 08:08:51 UTC
oVirt 3.4.4 has been released.


Note You need to log in before you can comment on or make changes to this bug.