Bug 1075137 - Patch Mgmt: "Rollback" button should be disabled, when "no items" are available in the table.
Summary: Patch Mgmt: "Rollback" button should be disabled, when "no items" are availab...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.3.0
Hardware: Unspecified
OS: Mac OS
unspecified
low
Target Milestone: DR5
: EAP 6.3.0
Assignee: Harald Pehl
QA Contact: Jakub Cechacek
Russell Dickenson
URL:
Whiteboard:
Depends On: 1074493
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-11 14:48 UTC by Liz
Modified: 2015-02-01 23:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-28 15:31:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Liz 2014-03-11 14:48:08 UTC
Description of problem:
When there are no file to rollback to, the "Rollback" button should be disabled. 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Navigate to the Patch Mgmt page.
2.When the table is empty, select the "Rollback" button
3.

Actual results:
"Rollback" button is active and receives focus.

Expected results:
"Rollback" button should be disabled when there are no patches populating the table. 

Additional info:

Comment 1 Radim Hatlapatka 2014-03-21 13:40:54 UTC
Verified with EAP 6.3.0.DR5

Comment 2 Liz 2014-05-13 15:24:25 UTC
Other button state comments: 
- When the table is empty (or when the system is NOT in a "restart required" state), should the "Restart" button be disabled as well?
- It might be helpful to provide tooltips for the Patch table buttons("Apply a New Patch, Rollback, Restart"), to offer more guidance around when/how they are used.

Comment 3 Harald Pehl 2014-05-14 07:40:46 UTC
In general changing button states depending on selection / state of a resource is hard to implement as it interfere with RBAC. That's the reason it is not done in the console in the current version. However I see the benefits behind it. I recommend to defer this feature to the next iteration.


Note You need to log in before you can comment on or make changes to this bug.