Bug 107516 - ooffice doesn't pick up gnome colors
ooffice doesn't pick up gnome colors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-19 18:01 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 11:41:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2003-10-19 18:01:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031018
Galeon/1.3.9

Description of problem:
By default ooffice uses a ugly color palette which reminds me of motif. ooffice
1.0.2 picks up the gnome colors which look much better, but 1.1.0 doesn't.

A workaround is

xprop -root -format GNOME_SM_PROXY 8i -set GNOME_SM_PROXY 1


Discussion can be found at

http://www.oooforum.org/forum/viewtopic.php?t=1281
http://gsl.openoffice.org/servlets/ReadMsg?msgId=820729&listName=dev

Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-2

How reproducible:
Always

Steps to Reproduce:
1. ooffice
2.
3.
    

Actual Results:  Ugly color palette

Expected Results:  Gnome like color palette

Additional info:
Comment 1 Dan Williams 2003-10-20 09:45:09 EDT
Can you give me some more details on your current setup and system?  Every box
I've tried 1.1 on results in the colors matching the current GNOME theme, even
when I've changed the theme the colors dynamically update to that theme's
colors.  Need to figure out why yours aren't doing the same since its always
worked for me.  Which window manager are you running too?

There should be another process running called "getstyle-gnome" or
"gnome-getstyle" (I can't remember which).  This is the process that picks up
the color differences.
Comment 2 Nathan G. Grennan 2003-10-20 10:28:28 EDT
I am using Gnome 2.4 with Sawfish. The program name you are looking for is
getstyle-gnome. It exists but I don't see it running. I do get the error message
below every time I run ooffice. I tried switching back to metacity with the same
results.

sed: can't read
/home/user/.openoffice/user/config/registry/instance/org/openoffice/Setup.xml:
No such file or directory
Comment 3 Dan Williams 2003-10-20 11:00:59 EDT
The error is known and to be solved in 1.1.0-3.

Can you post the permissions on getstyle-gnome for me?
Comment 4 Nathan G. Grennan 2003-10-20 11:17:03 EDT
-r-xr-xr-x    1 root     root         7316 Oct  8 07:32
/usr/lib/openoffice/program/getstyle-gnome
Comment 5 Dan Williams 2004-02-27 11:41:17 EST
Please try current OOo 1.1.0, and reopen if problem still occurs

Note You need to log in before you can comment on or make changes to this bug.