Bug 1075264 - Patch wizard inline error styling consistency
Summary: Patch wizard inline error styling consistency
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER2
: EAP 6.3.0
Assignee: Harald Pehl
QA Contact: Jakub Cechacek
Russell Dickenson
URL:
Whiteboard:
Depends On: 1074493
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-11 21:51 UTC by Liz
Modified: 2015-02-01 23:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-28 15:30:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Liz 2014-03-11 21:51:19 UTC
Description of problem:
1. Inline error messages should use consistent treatments. The "servers running" text now includes an alert icon - which makes it unclear whether it is an alert or read-only info/status text. 
2. Error screens: should use PatternFly styling, unless doing so would make them inconsistent with the rest of the application. 

Version-Release number of selected component (if applicable):

How reproducible:
100%

Steps to Reproduce:
1. Domain: Patch Mgmt > Apply a new patch
2. Shutdown servers?: No
3. View: Select or Confirm Patch Screens

Actual results:
Host info text includes a gray alert icon, inline. 

Expected results: "A" or "B".
A) A styled inline alert message and icon (similar to Error screen treatment).
B) No inline alert icon, just info/status text. 

Additional info:
Error messages should use PatternFly styling: https://site-patternfly.rhcloud.com/widgets/#alerts
* Unless doing so creates inconsistencies within the overall application.

Comment 1 Liz 2014-03-12 18:34:57 UTC
The design recommendation is:
Alternative B)
- On the Select and Confirm patch screens:
No inline alert icon, just info/status text. (ref: wireframes)

* If an inline warning is needed, it should instead be added to the "Shutdown Servers" screen instead.

Comment 2 Jakub Cechacek 2014-04-16 10:22:11 UTC
This issue will be verified with ER2 build due to BZ1081570.

Comment 3 Jakub Cechacek 2014-05-05 09:03:24 UTC
Verified ER2


Note You need to log in before you can comment on or make changes to this bug.