Bug 107528 - linux-gate.so on 2.6-test8
linux-gate.so on 2.6-test8
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elena Zannoni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-19 23:37 EDT by Jon Smirl
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 15:02:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Smirl 2003-10-19 23:37:23 EDT
The 2.6 kernel has added a new vsyscall feature called linux-gate.so.
linux-gate.so doesn't really exist and has no symbols. This trips up gdb and
requires numerous 'CONT' commands to skip over linux-gate.so issues.

gdb-5.3.90-0.20030710.41
I also tried gdb 6.0

gdb
/home/newtree/work/src/mesa/drivers/dri/r200/../../../../../progs/miniglx/miniglxtest
-fullname -nx -quiet
(gdb) set edit off 
(gdb) set confirm off 
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(gdb) 
(gdb) 
(gdb) set print static-members off 
(gdb) tty /dev/pts/1 
(gdb) set width 0 
(gdb) set height 0 
(gdb) set stop-on 1 
(gdb) handle SIG32 pass nostop noprint 
(gdb) handle SIG43 pass nostop noprint 
(gdb) set print asm-demangle on 
(gdb) cd /home/newtree/work/src/mesa/drivers/dri/r200/../../../../../progs/miniglx 
(gdb) break miniglx.c:725 
(gdb) run 
No source file named miniglx.c.
Error while mapping shared library sections:
linux-gate.so.1: Success.
(gdb) backtrace 
Error while reading shared library symbols:
linux-gate.so.1: No such file or directory.
[Thread debugging using libthread_db enabled]
[New Thread 1074271392 (LWP 32402)]
Stopped due to shared library event
#0  0x003f5e30 in _dl_debug_state_internal () from /lib/ld-linux.so.2
#1  0x003ead12 in dl_main () from /lib/ld-linux.so.2
#2  0x003f861a in _dl_sysdep_start () from /lib/ld-linux.so.2
#3  0x000000e0 in ?? ()
#4  0xbfffef34 in ?? ()
#5  0x2d000000 in ?? ()
#6  0x00000003 in ?? ()
#7  0xbfffefba in ?? ()
#8  0xffffe400 in ?? ()
#9  0xffffffff in ?? ()
(gdb) info thread 
[New Thread 1074271392 (LWP 32402)]
  2 Thread 1074271392 (LWP 32402)  0x003f5e30 in _dl_debug_state_internal ()
from /lib/ld-linux.so.2
(gdb) frame 0 
#0  0x003f5e30 in _dl_debug_state_internal () from /lib/ld-linux.so.2
(gdb) cont 
Error while reading shared library symbols:
linux-gate.so.1: No such file or directory.
[Switching to Thread 1074271392 (LWP 32402)]
Stopped due to shared library event
(gdb) cont 
Error while reading shared library symbols:
linux-gate.so.1: No such file or directory.
Stopped due to shared library event
(gdb) cont 
Error while reading shared library symbols:
linux-gate.so.1: No such file or directory.
Stopped due to shared library event
(gdb) cont 
Error while reading shared library symbols:
linux-gate.so.1: No such file or directory.

Stopped due to shared library event
(gdb) cont 

Program received signal SIGFPE, Arithmetic exception.
0x401bc7ab in _mesa_test_os_sse_exception_support () from
/usr/X11R6/lib/modules/dri/r128_dri.so
(gdb) backtrace 
#0  0x401bc7ab in _mesa_test_os_sse_exception_support () from
/usr/X11R6/lib/modules/dri/r128_dri.so
#1  0x401bc4d1 in check_os_sse_support () from
/usr/X11R6/lib/modules/dri/r128_dri.so
#2  0x401bc380 in sigill_handler () from /usr/X11R6/lib/modules/dri/r128_dri.so
(gdb) break miniglx.c:725 
Previous frame inner to this frame (corrupt stack?)
(gdb) frame 0 
No source file named miniglx.c.
#0  0x401bc7ab in _mesa_test_os_sse_exception_support () from
/usr/X11R6/lib/modules/dri/r128_dri.so
(gdb) frame 1 
#1  0x401bc4d1 in check_os_sse_support () from
/usr/X11R6/lib/modules/dri/r128_dri.so
(gdb) frame 0 
#0  0x401bc7ab in _mesa_test_os_sse_exception_support () from
/usr/X11R6/lib/modules/dri/r128_dri.so
Comment 1 Jon Smirl 2003-12-16 15:02:48 EST
This was fixed a few weeks ago in Fedora

Note You need to log in before you can comment on or make changes to this bug.