Bug 107532 - RHSA-2003:256-10 - Perl update breaks Amavis.
RHSA-2003:256-10 - Perl update breaks Amavis.
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-10-20 03:10 EDT by Tommy Sandquist
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-07 06:19:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tommy Sandquist 2003-10-20 03:10:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030716

Description of problem:
The critical update Errata #: RHSA-2003:256-10 seems to break Perl. The update
takes the existing version in RedHat 8.0 from 5.8.0-55 to 5.8.0-88.3.
Immediately after applying this update I noticed my mail anti-virus scanner
(AMAVIS) was no longer running. After identifying that the mail scanner stopped
at the same time as the Perl updates I proceeded to remove Perl 5.8.0-88.3 and
the corresponding Perl-CGI and Perl-CPAN packages. I then reinstall Perl
5.8.0-55 and the corresponding Perl-CGI and Perl-CPAN packages. AMAVIS started
working properly after the Perl revert. To verify that my server wasn't
corrupting data I built another RedHat 8.0 box with a clean install. I installed
the Perl packages necessary for AMAVIS and tested the scanner to make sure it
was working. I then installed all of the corresponding RH8 Errata. AMAVIS failed
after the updates. I tried rebuilding the Perl packages and received errors
regarding pod2man not being in the path. I tried resetting the LANG variable
from en_US.UTF-8 to en_US which resolved the pod2man error but still did not
resolve the issues with AMAVIS. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Load Amavis-0.3.12 and all necessary components.
2.Apply update: RHSA-2003:256-10
3.Send a test message then view your maillog.

Actual Results:  No worky...

Expected Results:  Hopefully my mail gets scanned for viruses and then delivered
to my mailbox.

Additional info:

AMAVIS creates the following log entries in /etc/log/maillog when receiving mail:

Oct 19 23:30:16 localhost amavisd[2094]: starting.  amavis 0.3.12 Sun Oct 19
20:36:45 PDT 2003
Oct 19 23:30:16 localhost amavisd[2097]: mail forwarding failed, retry: Insecure
dependency in exec while running with -T switch at /usr/sbin/amavis line 578,
<GEN0> line 17. (message-id=<200310200532.h9K5Wd9q031494@mail.toms-games.com>)
Oct 19 23:30:16 localhost amavisd[2097]: do_exit:476 - ending execution with 75
Oct 19 23:30:16 localhost amavisd[2094]: do_exit:591 - ending execution with 75
Oct 19 23:30:16 localhost sendmail[2088]: h9K5Wefs001024:
to=<tomsand@skynet.toms-games.com>, delay=00:57:36, xdelay=00:00:01,
mailer=local, pri=120782, dsn=4.0.0, stat=Deferred: local mailer
(/usr/sbin/amavis) exited with EX_TEMPFAIL

When running 'make check' during the installation of AMAVIS I receive the following:

Making check in amavis
make[1]: Entering directory `/home/tomsand/amavis/amavis-0.3.12/amavis'
make[1]: Nothing to be done for `check'.
make[1]: Leaving directory `/home/tomsand/amavis/amavis-0.3.12/amavis'
Making check in tests
make[1]: Entering directory `/home/tomsand/amavis/amavis-0.3.12/tests'
make  check-TESTS
make[2]: Entering directory `/home/tomsand/amavis/amavis-0.3.12/tests'
PASS: config
PASS: novirus-msg
FAIL: virus-msg
PASS: xheader
1 of 4 tests failed
make[2]: *** [check-TESTS] Error 1
make[2]: Leaving directory `/home/tomsand/amavis/amavis-0.3.12/tests'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/home/tomsand/amavis/amavis-0.3.12/tests'
make: *** [check-recursive] Error 1

I have listed the versions of software I am using below.
Kernel Version: 2.4.20-20.8
RedHat Version: 8.0 3.2-7
Amavis Version: 0.3.12 (Perl)
AV-Scanner: Uvscan 4.24e
Comment 1 Charles Curley 2003-10-21 10:55:55 EDT
Further information. The perl upgrade appears to have also broken htmlpp, a
processor for creating web pages with cross links, etc. It appears to be failing
on the following code snippet:

    elsif (/^(\-ifexist\s+)?([^\s!]+)(!)?/) {          #  .include filename[!]

The failure being that .include statements which were previously acceptable now
Comment 2 Guðmundur D. H. 2004-05-30 17:10:24 EDT
Similar thing is happening on Fedora Core 2 with amavisd-0.1:

May 30 20:33:30 XXXX amavisd[21198]: Decoding of msg-21195-2.arc (ARC
archive data, packed) failed, leaving it unpacked: Insecure dependency
in exec while running with -T switch at /usr/sbin/amavisd line 827,
<GENO> line 57. (message-id=<2004053002035.i4UKZiBu021192@XXXX>)

Also, amavis (I don't know about amavisd) has some problems on Fedora
Core 1, leaving it unusable on that platform.

Comment 3 Oak 2004-07-23 06:22:58 EDT
Also, amavisd has some problems on Fedora
Core 2, leaving it unusable on that platform
Comment 4 Oak 2004-07-23 06:24:57 EDT
fedora core 2 with amavis-0.3.13pre2 has this problem too.  

Note You need to log in before you can comment on or make changes to this bug.