Bug 107546 - splittree.py crashed with Traceback
splittree.py crashed with Traceback
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-20 09:59 EDT by Uwe Beck
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-20 15:24:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2003-10-20 09:59:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (X11; I; AIX 4.3)

Description of problem:
Create new CDs from a sourcetree it is nomaly possible by useing
/usr/lib/anaconda-runtime/splittree.py.

I have a sourcetree /lex021/distredhat/rh295as/i386 (like kickstart server).
The "buildinstall" program was run over this directory without faults.

ls /lex021/distredhat/rh295as/i386
.discinfo
autorun
beta_eula.txt
dosutils
GPL
images
isolinux
README
README-de
README-en
README-es
README-fr
README-it
README-ja
README-ko
README-pt_BR
README-zh_CN
README-zh_TW
RedHat
RELEASE-NOTES-de.html
RELEASE-NOTES-en
RELEASE-NOTES-en.html
RELEASE-NOTES-es.html
RELEASE-NOTES-fr.html
README-it
README-ja
README-ko
README-pt_BR
README-zh_CN
README-zh_TW
RedHat
RELEASE-NOTES-de.html
RELEASE-NOTES-en
RELEASE-NOTES-en.html
RELEASE-NOTES-es.html
RELEASE-NOTES-fr.html
RELEASE-NOTES-it.html
RELEASE-NOTES-ja.html
RELEASE-NOTES-ko.html
RELEASE-NOTES-pt_BR.html
RELEASE-NOTES-zh_CN.html
RELEASE-NOTES-zh_TW.html
RPM-GPG-KEY
RPM-GPG-KEY-beta
SRPMS
TRANS.TBL

Now it is time to split the distro. The new tool ist "splittree.py".

export PYTHONPATH=/usr/lib/anaconda
export PATH="$PATH:/usr/lib/anaconda-runtime"
cd /usr/lib/anaconda-runtime
# create the pkgorder file for splittree.py if it was not done before
./pkgorder /lex021/distredhat/rh295as/i386 i386 >pkgorder.txt
# split the distro
./splittree.py --arch=i386 --total-discs=6 --bin-discs=3 --src-discs=3
--release-string="Red Hat Linux" --pkgorderfile=pkgorder.txt 
--distdir=/lex021/distredhat/rh295as/i386
--srcdir=/lex021/distredhat/rh295as/i386/SRPMS

(it is one line)

The result is:
Traceback (most recent call last):
  File "./splittree.py", line 451, in ?
    logfile = timber.main()
  File "./splittree.py", line 379, in main
    self.splitRPMS()
  File "./splittree.py", line 252, in splitRPMS
    pkg_nvr = nvra("%s/RedHat/RPMS/%s" %(self.dist_dir, filename))
  File "./splittree.py", line 39, in nvra
    h = _ts.hdrFromFdno(fd)
rpm.error: public key not trusted

RPM-GPG-KEY and RPM-GPG-KEY-beta are imported with "rpm --import key"

Without  the funktion self.splitRPMS() the split of the SRPMS (CD4, CD5, CD6)
works correct.

    def main(self):
        """Just runs everything"""
        self.createSplitDirs()
        # self.splitRPMS()
        self.splitSRPMS()
        return self.logfile



Version-Release number of selected component (if applicable):
anaconda-runtime-9.0.6-0.RHEL.20030828190309

How reproducible:
Always

Steps to Reproduce:
1. Create the sourcetree and run "buildinstall" and "pkgorder"
2. Split the distro with "splittree.py"
3.
    

Actual Results:  Unable to create the binary CDs

Expected Results:  Can create all CDs

Additional info:
Comment 1 Jeremy Katz 2003-10-20 15:24:44 EDT
One of your packages is signed with a different key (either one you don't have
imported or one that you've somehow assigned a lack of trust to).

It works for me here in our buildroots.
Comment 2 Uwe Beck 2003-10-21 07:58:35 EDT
Exactly. It was the file TRANS.TBL in the RPMS directory. The old tool
"splitdistro" was tolerant in this case. I think it is a good concept now.

Note You need to log in before you can comment on or make changes to this bug.