Bug 107551 - OOo crashes when trying to opne MySQL database to creat tables
OOo crashes when trying to opne MySQL database to creat tables
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: unixODBC (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-20 11:29 EDT by Dennis Gilmore
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-28 08:00:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text report generated by OO before dying (45.08 KB, text/plain)
2003-10-29 13:49 EST, Denice
no flags Details

  None (edit)
Description Dennis Gilmore 2003-10-20 11:29:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030913

Description of problem:
everytime I try to use OOo with MySQL as a data souce it crahses  when trying to
open to create a Table.  unixODBC connects fine.  

Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-2

How reproducible:
Always

Steps to Reproduce:
1. Open oowriter
2. select DataSource
3. try to create table
    

Actual Results:  OOo Crashes

Expected Results:  able to create a table. and enter data in it.

Additional info:

i have had the exact same problem on two machines running FC test3 with all
updates from rawhide as at 21/10/2003
Comment 1 Denice 2003-10-29 06:13:13 EST
I'm not seeing this problem on RH 9 with openoffice.org-1.1.0-2   I can create
and delete tables in a preexisting database with no problems.  I'll give this a
try also in FC test3 when I reinstall a test machine later today..

Currently installed on RH 9:
$ rpm -qa |grep -iE '(odbc|openoffice)'|sort
MyODBC-2.50.39-11
openoffice.org-1.1.0-2
openoffice.org-i18n-1.1.0-2
openoffice.org-libs-1.1.0-2
php-odbc-4.2.2-17.3
unixODBC-2.2.3-6
unixODBC-devel-2.2.3-6
Comment 2 Denice 2003-10-29 13:46:48 EST
I can now confirm that OOo dies when trying to create a new table on FC test3
with all necessary RPMs updated from rawhide. As noted previously, I have no
problems with openoffice.org-1.1.0-2 on RH 9.  I'm attaching the generated error
report.

$ rpm -qa |grep -iE '(openoffice|odbc)'|sort
MyODBC-2.50.39-17
openoffice.org-1.1.0-3
openoffice.org-i18n-1.1.0-3
openoffice.org-libs-1.1.0-3
unixODBC-2.2.5-9
Comment 3 Denice 2003-10-29 13:49:32 EST
Created attachment 95585 [details]
text report generated by OO before dying
Comment 4 Dennis Gilmore 2003-10-30 00:57:50 EST
Changing bug to unixODBC  after Denice  saying that database access worked 
correctly with OOo 1.1 on RH9 i downloaded and installed the versions of 
unixODBC from RH 9 on FC test3 and everything worked as expected. the only 
change being unixODBC and unixODBC-kde  
Comment 5 Denice 2003-10-31 05:48:40 EST
I downloaded the updates for FC 3 this morning to test the new version of
openoffice 1.1.0-4  with odbc stuff.  It still dies if you try to create new
tables from the Data Administration interface (Tools -> Data sources).  However
if you access the data sources from an open document; ie:
 View -> Data Sources
Then you can can create and delete tables.
Comment 6 Dennis Gilmore 2003-10-31 06:27:52 EST
I can confirm Denice's findings  when using View -> Data Sources  as opposed to
Tools -> Data Sources everything works as expected.  this is with
unixODBC-2.2.5-9 however as stated earlier using unixODBC-2.2.3-6 from RH9
everything works as expected.  Does anyone know if the two seperate menu
functions call the same code to create the tables?  if they dont they should and
it should be fixed upstream. If however they share the code then what can i do
to determine the cause.
i currently have installed

openoffice.org-i18n-1.1.0-4.4
openoffice.org-libs-1.1.0-4.4
openoffice.org-1.1.0-4.4
unixODBC-2.2.5-9
unixODBC-kde-2.2.5-9
myODBC-2.50.39-17

my MySQL server is on a RH 8.0 server 

Comment 7 Dennis Gilmore 2003-10-31 06:49:51 EST
heres the console output from when OOo crashes

oowriter
Starting OpenOffice.org ...


Fatal exception: Signal 11
Stack:
/usr/lib/openoffice/program/libsal.so.3[0x122a78]
/usr/lib/openoffice/program/libsal.so.3[0x122c05]
/usr/lib/openoffice/program/libsal.so.3[0x122cce]
/lib/tls/libpthread.so.0[0x88bf18]
/usr/lib/libodbc.so.1(SQLDriverConnect+0x3df)[0x1cc3dbf]
/usr/lib/openoffice/program/libodbcbase2.so(_ZN12connectivity4odbc11OConnection14OpenConnectionERKN3rtl8OUStringElh+0x1d8)[0x1b8eb96]
/usr/lib/openoffice/program/libodbcbase2.so(_ZN12connectivity4odbc11OConnection9ConstructERKN3rtl8OUStringERKN3com3sun4star3uno8SequenceINS8_5beans13PropertyValueEEE+0xa0d)[0x1b8f961]
/usr/lib/openoffice/program/libodbcbase2.so(_ZN12connectivity4odbc10ODBCDriver7connectERKN3rtl8OUStringERKN3com3sun4star3uno8SequenceINS8_5beans13PropertyValueEEE+0x220)[0x1b8b36a]
/usr/lib/openoffice/program/libmysql2.so[0x1c77d03]
/usr/lib/openoffice/program/libdbpool2.so[0x1adff9d]
/usr/lib/openoffice/program/libdbpool2.so[0x1adf964]
/usr/lib/openoffice/program/libdbpool2.so[0x1ae46e4]
/usr/lib/openoffice/program/libdba645li.so[0x1a8bff7]
/usr/lib/openoffice/program/libdba645li.so[0x1a8f2f8]
/usr/lib/openoffice/program/libdba645li.so[0x1a86497]
/usr/lib/openoffice/program/libdba645li.so[0x1a8f60a]
/usr/lib/openoffice/program/libdba645li.so[0x1a8ea5b]
/usr/lib/openoffice/program/libdbu645li.so[0x165efd3]
/usr/lib/openoffice/program/libdbu645li.so[0x173c01c]
/usr/lib/openoffice/program/libdbu645li.so[0x173bf68]
/usr/lib/openoffice/program/libdbu645li.so[0x165cb70]
/usr/lib/openoffice/program/libdbu645li.so[0x15e84fb]
/usr/lib/openoffice/program/libdbu645li.so[0x15e63a3]
/usr/lib/openoffice/program/libdbu645li.so[0x17446f4]
/usr/lib/openoffice/program/libfwk645li.so[0x304c244]
/usr/lib/openoffice/program/libfwk645li.so[0x30521b2]
/usr/lib/openoffice/program/libfwk645li.so[0x3045988]
/usr/lib/openoffice/program/libfwk645li.so[0x30600ca]
/usr/lib/openoffice/program/libdbu645li.so[0x169473a]
/usr/lib/openoffice/program/libdbu645li.so[0x16942d7]
/usr/lib/openoffice/program/libdbu645li.so[0x16c5f69]
/usr/lib/openoffice/program/libdbu645li.so[0x16c66ad]
/usr/lib/openoffice/program/libdbu645li.so[0x16c6686]
/usr/lib/openoffice/program/libvcl645li.so(_ZN7ToolBox6SelectEv+0x4e)[0x77d3872]
/usr/lib/openoffice/program/libvcl645li.so(_ZN7ToolBox23ImplHandleMouseButtonUpERK10MouseEventh+0x157)[0x77ce6b7]
/usr/lib/openoffice/program/libvcl645li.so(_ZN7ToolBox8TrackingERK13TrackingEvent+0x45)[0x77cf499]
/usr/lib/openoffice/program/libvcl645li.so(_ZN6Window11EndTrackingEt+0x155)[0x77ee9df]
/usr/lib/openoffice/program/libvcl645li.so(_Z20ImplHandleMouseEventP6Windowthllmtt+0x1010)[0x77f10c0]
/usr/lib/openoffice/program/libvcl645li.so(_Z19ImplWindowFrameProcPvP8SalFrametPKv+0xc6)[0x77f391e]
/usr/lib/openoffice/program/libvcl645li.so(_ZN12SalFrameData16HandleMouseEventEP7_XEvent+0x46a)[0x7852bbe]
/usr/lib/openoffice/program/libvcl645li.so(_ZN12SalFrameData8DispatchEP7_XEvent+0x135)[0x7854abb]
/usr/lib/openoffice/program/libvcl645li.so(_ZN10SalDisplay8DispatchEP7_XEvent+0x29a)[0x7880c56]
/usr/lib/openoffice/program/libvcl645li.so(_ZN10SalDisplay5YieldEh+0x13c)[0x788099a]
/usr/lib/openoffice/program/libvcl645li.so[0x787c76d]
/usr/lib/openoffice/program/libvcl645li.so(_ZN7SalXLib5YieldEh+0x423)[0x787b1c7]
/usr/lib/openoffice/program/libvcl645li.so(_ZN11SalInstance5YieldEh+0x34)[0x7884256]
/usr/lib/openoffice/program/libvcl645li.so(_ZN11Application5YieldEv+0x61)[0x76ac0e7]
/usr/lib/openoffice/program/libvcl645li.so(_ZN6Dialog7ExecuteEv+0x1e9)[0x77a0d3f]
/usr/lib/openoffice/program/libsfx645li.so(_ZN12SfxTabDialog7ExecuteEv+0x42)[0x3d01fa0]
/usr/lib/openoffice/program/libdbu645li.so[0x16f6f7d]
/usr/lib/openoffice/program/libsvt645li.so(_ZN3svt17OGenericUnoDialog7executeEv+0x23a)[0x7b931c2]
/usr/lib/openoffice/program/libofa645li.so(_ZN17OfficeApplication13BaseExec_ImplER10SfxRequest+0x244)[0x34030f4]
/usr/lib/openoffice/program/libofa645li.so(_Z37SfxStubOfficeApplicationBaseExec_ImplP8SfxShellR10SfxRequest+0x26)[0x34010f0]
/usr/lib/openoffice/program/libsfx645li.so(_ZN13SfxDispatcher9Call_ImplER8SfxShellRK7SfxSlotR10SfxRequesth+0x5a1)[0x3c4a213]
/usr/lib/openoffice/program/libsfx645li.so(_ZN13SfxDispatcher8_ExecuteER8SfxShellRK7SfxSlotR10SfxRequestt+0x174)[0x3c4b61e]
/usr/lib/openoffice/program/libsfx645li.so(_ZN11SfxBindings12Execute_ImplER10SfxRequestPK7SfxSlotP8SfxShell+0x350)[0x3c5b540]
/usr/lib/openoffice/program/libsfx645li.so(_ZN11SfxBindings12Execute_ImplEtPPK11SfxPoolItemttS3_h+0x3ca)[0x3c5b122]
/usr/lib/openoffice/program/libsfx645li.so(_ZN11SfxBindings7ExecuteEtPPK11SfxPoolItemttS3_+0x65)[0x3c5ace1]
/usr/lib/openoffice/program/libsfx645li.so(_ZN14SfxVirtualMenu6SelectEP4Menu+0x543)[0x3c77d8f]
/usr/lib/openoffice/program/libsfx645li.so(_ZN14SfxVirtualMenu14LinkStubSelectEPvS0_+0x26)[0x3c77844]
/usr/lib/openoffice/program/libvcl645li.so(_ZN4Menu6SelectEv+0x5e)[0x77a7b72]
/usr/lib/openoffice/program/libvcl645li.so(_ZN4Menu14ImplCallSelectEPS_+0x18)[0x77ab93c]
/usr/lib/openoffice/program/libvcl645li.so(_ZN4Menu22LinkStubImplCallSelectEPvS0_+0x26)[0x77ab91c]
/usr/lib/openoffice/program/libvcl645li.so[0x77f34a2]
Aborted
Comment 8 Dan Williams 2003-10-31 13:46:30 EST
Dennis,

Did you install the OOo debuginfo package?
Comment 9 Dennis Gilmore 2003-10-31 19:18:18 EST
no i didnt't but can do if it will help. 
Comment 10 Dan Williams 2004-02-27 11:44:30 EST
dennis, can you try reproducing wtih latest OOo?  Thanks...
Comment 11 Denice 2004-03-02 08:14:10 EST
I gave it a shot with the latest oOO on a FC 2 test1 system updated
with the latest from devel (this morning). It still dies, and bug
buddy comes up. 

# rpm -qa |grep -iE '(openoffice|odbc)'|sort
MyODBC-2.50.39-18
openoffice.org-1.1.0-28
openoffice.org-i18n-1.1.0-28
openoffice.org-libs-1.1.0-28
unixODBC-2.2.5-11
unixODBC-devel-2.2.5-11

Let me know what I can do.
  ..denice
Comment 12 Caolan McNamara 2004-10-28 03:47:43 EDT
This might be the same as #110595. If unixODBC >= 2.2.8 is used does
it still crash ?
Comment 13 Dennis Gilmore 2004-10-28 08:00:16 EDT
i currently have installed unixODBC-2.2.9-1 and it is working as 
expected.   

Note You need to log in before you can comment on or make changes to this bug.