Bug 1075600 - Test case failure: GNOME Shell - 3D rendering on ATI Kaveri [1002:1304]
Summary: Test case failure: GNOME Shell - 3D rendering on ATI Kaveri [1002:1304]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jérôme Glisse
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-12 12:54 UTC by Vasiliy Sharapov
Modified: 2015-11-19 04:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 04:19:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
glxinfo stdout (18.79 KB, text/x-log)
2014-03-15 00:46 UTC, Vasiliy Sharapov
no flags Details
glxinfo stderr (96 bytes, text/plain)
2014-03-15 00:46 UTC, Vasiliy Sharapov
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2198 normal SHIPPED_LIVE Xorg server and driver bug fix and enhancement update 2015-11-19 08:04:34 UTC

Description Vasiliy Sharapov 2014-03-12 12:54:33 UTC
Filed from caserun https://tcms.engineering.redhat.com/run/117767/#caserun_4400560

Version-Release number of selected component (if applicable):
RHEL-7.0-20140214.0

Steps to Reproduce: 
 1. log into GNOME Shell with 3D capable graphic device
 2. install glx-utils
 3. open a terminal


 1. run glxinfo |grep rendering
 2. run glxgears
     1. move glxgears window around (you can go to Overview as well)
     2. resize the window to full screen and back



Actual results: 
"Error: couldn't find RGB GLX visual or fbconfig"
(Full log attached)
glxgears appears to be fine

Expected results:
glxinfo should show: direct rendering: Yes and OpenGL renderer string shouldn't
be llvmpipe or any other software renderer

there should be neither graphical glitches nor crash while moving the glxgears
window around

Comment 1 Vasiliy Sharapov 2014-03-15 00:46:13 UTC
Created attachment 874671 [details]
glxinfo stdout

Comment 2 Vasiliy Sharapov 2014-03-15 00:46:36 UTC
Created attachment 874672 [details]
glxinfo stderr

Comment 6 Vasiliy Sharapov 2015-09-16 19:55:11 UTC
Verified fixed in:
RHEL-7.2-20150820.0
xorg-x11-server-Xorg-1.17.2-7.el7.x86_64
xorg-x11-drv-ati-7.5.0-3.el7.x86_64
kernel-3.10.0-306.0.1.el7.x86_64
linux-firmware-20150727-41.git75cc3ef.el7.noarch
mesa-dri-drivers-10.6.0-1.20150616.el7.x86_64

Comment 7 errata-xmlrpc 2015-11-19 04:19:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html


Note You need to log in before you can comment on or make changes to this bug.