Bug 107567 - rdist only passes 40 lines of environment to rsh
Summary: rdist only passes 40 lines of environment to rsh
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rdist   
(Show other bugs)
Version: 2.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL: http://ftp.rge.com/pub/systems/aix/ai...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-20 18:16 UTC by Stephen Walton
Modified: 2015-03-05 01:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 13:11:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script which runs ssh (69 bytes, text/plain)
2003-10-20 18:18 UTC, Stephen Walton
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2004:077 normal SHIPPED_LIVE An updated rdist package is available 2004-05-12 04:00:00 UTC
Red Hat Product Errata RHEA-2004:170 normal SHIPPED_LIVE An updated rdist package is available 2004-04-21 04:00:00 UTC

Description Stephen Walton 2003-10-20 18:16:57 UTC
Description of problem:

rdist 6.1.5 imposes an arbitrary limit of 40 lines of environment which is
passed to rsh or its equivalent specified via -P.  The URL contains a patch
(which appears to be about three years old) which fixes the problem.

Version-Release number of selected component (if applicable):

6.1.5

How reproducible:

Always

Steps to Reproduce:
1.  Create more than 40 lines of environment variables in a shell
2.  Run "rdist -P $HOME/debug-ssh -c foobar remotehost" where "foobar" is some
file or directory and $HOME/debug-ssh is attached as a bash script.
3.  Examine the log file "logfile" created by debug-ssh.
    
Actual results:

You will see that only 40 lines of environment variables are passed to the ssh
spawned by rdist.

Expected results:

All environment variables from the parent shell should be passed to rsh/ssh by
rdist.

Additional info:

I spent three days tracking this one down.  It prevents ssh-agent from working
properly with rdist, because if one's environment variable becomes longer than
40 values, the values created by `eval ssh-agent` may not get passed to ssh by
rdist.  Thus a script which uses ssh-agent, ssh-add, and rdist will inexplicably
work sometimes and fail other times.

Comment 1 Stephen Walton 2003-10-20 18:18:17 UTC
Created attachment 95315 [details]
Script which runs ssh

This script creates a "logfile" which contains the output of a "printenv"
command followed by the error output of "ssh -vvv".

Comment 2 Phil Knirsch 2003-10-21 13:11:01 UTC
If you would have looked at all open rdist bugs you could have saved these 3
days. ;-) Bug 85634 exactly describes the same problem and the latest rawhide
version of rdist has already a fix for it.

Read ya, Phil

Comment 3 John Flanagan 2004-04-22 00:29:36 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2004-170.html



Note You need to log in before you can comment on or make changes to this bug.