Bug 107568 - cannot create boot diskette as part of install
cannot create boot diskette as part of install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-20 14:26 EDT by Don Russell
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 14:40:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog file created after initial boot from CD1 (8.21 KB, text/plain)
2003-10-21 11:49 EDT, Don Russell
no flags Details

  None (edit)
Description Don Russell 2003-10-20 14:26:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
After going through the install, a screen gives me the opportunity to create a 
boot diskette.

I say yes, use a newly formatted diskette...

It starts to do something with the disk (I can hear the cover slide open etc... 
then "an error occured"...

Happens every time, I've tried reinattling from scratch many times (doing a 
clean/reformat instal each time)

I installed Redhat Linux 9.0 and used the same floppy disk... no problems....

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from CD1
2. Do a clean workstaion/defaults install
3. Select option yes to create a boot diskette
    

Actual Results:  A screen pops up saying an error was detected

Expected Results:  The boot diskette should have been created

Additional info:

Hardware:
IBM Netvista A60 6833-61U with a second hard disk.
2nd hard disk is Western digital 120GB. (brand new)

IDE bus:
Primary master: original hard disk
Primary slave: none
Secondary master: new hard disk
Secondary slave: CD-ROM drive



Actually I think this symptom is a red herring, the real problem is there are 
lots of install errors (but there's no indication of that until much later)

When the system is shutting down to restart for "first boot", I get screen 
fulls of 

"rpmdb fatal region error detected; run recovery"

Then the machine reboots and gets hung just after activating swap space....

I was able to get to "/root/install.log" and it shows all sorts of rpm errors 
beginning with the installation of groff...

groff-1.18.1-29.i386
Comment 1 Jeremy Katz 2003-10-20 14:35:29 EDT
Can you please verify your installation media following the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html?
Comment 2 Don Russell 2003-10-20 15:00:32 EDT
I did a media test as part of the initial install, testing all three CDs.
Only two CDs were used for the install (Workstation, use default software)

I did configure firewall...
allowing WWW, FTP, SSH, and 515:tcp,123:udp

I also added the "improved ftp client"

I used these CDs to successfully install on another machine, so it's not a 
media problem.

When I boot from CD1, some messages flash by very quickly, but one of them 
says "ide late registration from device" or something very similar.... those 
messages are lost, I don't know how to keep them, or pause things so I can 
write them down.
Comment 3 Jeremy Katz 2003-10-20 15:47:20 EDT
You should be able to grab /tmp/syslog while in the installer and either copy it
to a floppy or scp it off (or copy it to the install system filesystem)
Comment 4 Don Russell 2003-10-20 15:52:43 EDT
OK, what are the commands to copy it to floppy?

I'm a little new to Linux and not really familiar with all the mount commands 
etc...

Once I have that, I'll try it again this afternoon and put the results up here.
Comment 5 Jeremy Katz 2003-10-20 16:03:44 EDT
You should just be able to run `mcopy /tmp/syslog a:`
Comment 6 Don Russell 2003-10-20 17:35:01 EDT
Well.... after the initial boot from CD, I didn't know how to get back to a 
command prompt.

After 'firstboot', I was able to get to a command line (graphic login didn't 
start) so I logged in as root.

/tmp has nothing in it....

I tried to copy /var/log/install.log to floppy with
mcopy /var/log/install.log a:

error--> mcopy is an unknown command, so I tried cp
and ended up with a file called a:


Comment 7 Jeremy Katz 2003-10-20 17:56:24 EDT
If you switch to tty2 while the installer is running, you'll get a shell prompt.
Comment 8 Don Russell 2003-10-20 18:04:56 EDT
How do I switch to tty2 while the installer is running?
Comment 9 Jeremy Katz 2003-10-20 18:42:10 EDT
Ctrl-alt-F2
Comment 10 Don Russell 2003-10-21 11:49:01 EDT
Created attachment 95348 [details]
syslog file created after initial boot from CD1

Notice the messages regarding "late registration" regarding IDE...
Comment 11 Jeremy Katz 2004-09-22 14:40:31 EDT
We can't do boot disks anymore with the size of the 2.6 kernel.

Note You need to log in before you can comment on or make changes to this bug.