Bug 107569 - swallows control-* after viewport navigation
Summary: swallows control-* after viewport navigation
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: metacity   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-20 18:36 UTC by Michael Stenner
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 19:12:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Stenner 2003-10-20 18:36:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I have control-<arrows> set to change viewports.  When I press control and start
hitting arrow keys, it changes between viewports and pops up the little "map" of
my desktop.  If I move to my target viewport and keep control pressed, the "map"
stays there (this is good).  However, if I then press a key that metacity should
not respond to, it "swallows" that key.  A typical scenario is this:

1) navigate to my xemacs window with control-<arrows>
2) (still holding control) hit "x", then "s"
3) xemacs only "sees"  the control-s

If I instead lift the control key and re-press it before hitting "x", it works fine.

Version-Release number of selected component (if applicable):
metacity-2.4.34-3

How reproducible:
Always

Steps to Reproduce:
1. bind control-<arrows> to change viewports (left, right, etc)
2. move viewports to an active window
3. without releasing control, press a key that metacity should pass through.  It
doesn't.  It will pass the NEXT one through, though.
    

Additional info:

Comment 1 Havoc Pennington 2004-05-25 19:12:34 UTC
I don't think this is possible to fix, due to the technical details of
how it's implemented. Metacity is capturing all key events while in
"move between workspaces" mode (otherwise it could miss the key
release and get stuck in the mode), and there's no way to pass through
a key once it's been captured.

I'm of course open to a patch if someone is smarter than I am. This
bug may also be on gnome.org with other comments, I'm not sure.


Note You need to log in before you can comment on or make changes to this bug.