Bug 1075705 - yum-config-manager --save doesn't work
Summary: yum-config-manager --save doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Packaging Maintenance Team
QA Contact: Karel Srot
URL:
Whiteboard:
: 1102105 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-12 15:56 UTC by Karel Srot
Modified: 2014-10-14 04:38 UTC (History)
2 users (show)

Fixed In Version: yum-utils-1.1.30-23.el6
Doc Type: Bug Fix
Doc Text:
Cause: run "yum-config-manager --setopt='debuglevel=9' --save" Consequence: crash Fix: patch was added to fix the crash Result: no crash
Clone Of:
Environment:
Last Closed: 2014-10-14 04:38:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1411 normal SHIPPED_LIVE yum-utils bug fix update 2014-10-14 00:54:50 UTC

Description Karel Srot 2014-03-12 15:56:24 UTC
Description of problem:

# yum-config-manager --setopt='debuglevel=9' --save
...
...
timeout = 30.0
tolerant = True
tsflags = 
username = 

Traceback (most recent call last):
  File "/usr/bin/yum-config-manager", line 154, in <module>
    writeRawConfigFile(fn, 'main', ybc.conf.yumvar,
AttributeError: 'YumConf' object has no attribute 'conf'


And nothing is saved. 

yum-utils-1.1.30-17.el6_5.noarch


Expected behavior:

  yum-config-manager options:
    --save              save the current options (useful with --setopt)

Comment 1 Valentina Mukhamedzhanova 2014-03-12 16:30:53 UTC
There is an upstream fix http://yum.baseurl.org/gitweb?p=yum-utils.git;a=commitdiff;h=2aac1b1c8b3f5ada029d6772ee6f9bb7c63be172

Comment 4 Valentina Mukhamedzhanova 2014-05-28 13:55:34 UTC
*** Bug 1102105 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2014-10-14 04:38:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1411.html


Note You need to log in before you can comment on or make changes to this bug.