Bug 1075834 - Bad rendering of pop-up dialogs in anaconda on current Rawhide live images
Summary: Bad rendering of pop-up dialogs in anaconda on current Rawhide live images
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: rawhide
Hardware: x86_64
OS: All
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-13 00:46 UTC by Adam Williamson
Modified: 2014-05-30 20:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-30 20:49:23 UTC
Type: Bug


Attachments (Terms of Use)
first example image (95.12 KB, image/png)
2014-03-13 00:47 UTC, Adam Williamson
no flags Details
second example image (106.62 KB, image/png)
2014-03-13 00:48 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2014-03-13 00:46:38 UTC
When running anaconda from the live environment on current Rawhide live images, rendering of pop-up dialogs is kind of odd, with text and buttons spilling over the borders. See attached screenshots. This is with an image I built from today's Rawhide primarily to test efibootmgr 0.7, just noticed this issue in passing.

Comment 1 Adam Williamson 2014-03-13 00:47:14 UTC
Created attachment 873773 [details]
first example image

Comment 2 Adam Williamson 2014-03-13 00:48:15 UTC
Created attachment 873774 [details]
second example image

Comment 3 Chris Lumens 2014-03-18 15:37:45 UTC
Yeah I see this too, but only on live images (not boot.iso), and even if I disable lightboxing.

Comment 4 Chris Lumens 2014-03-18 21:03:22 UTC
Here, have a reproducer:

#!/usr/bin/python
from gi.repository import Gtk

dlg = Gtk.MessageDialog(text="This looks terrible",
                        buttons=Gtk.ButtonsType.OK)
dlg.set_decorated(False)

dlg.show_all()
Gtk.main()

Comment 5 Chris Lumens 2014-03-18 21:10:16 UTC
Okay, on the anaconda side... I need to look at setting dialogs to non-resizeable if that is what we want, and also at setting them to decorated (provided it doesn't look crazy on non-gnome live images).  On the GTK side, it looks like there's a legitimate bug here with non-decorated windows.  Just try toggling set_decorated in that reproducer.

I don't need a bug report to track the anaconda things I mentioned.  I've got a whiteboard.

Comment 6 Matthias Clasen 2014-03-21 17:55:13 UTC
A bug, no question. But why are you making your dialogs undecorated ?

Comment 7 Matthias Clasen 2014-03-21 19:43:14 UTC
Fixed in https://git.gnome.org/browse/gtk+/commit/?id=9ed2c8a71988079f94a204d2e7d19d3bcad5c933

Fix will be in 3.12.0 next week.

Comment 8 Kalev Lember 2014-05-30 20:49:23 UTC
Closing the ticket; this should all be fixed by now.


Note You need to log in before you can comment on or make changes to this bug.