Bug 107586 - Tux Racer unusable with default driver for nVidia GeForce 4MX
Tux Racer unusable with default driver for nVidia GeForce 4MX
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-20 16:32 EDT by Rick Wood
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 02:02:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Wood 2003-10-20 16:32:37 EDT
Description of problem:
Tux Racer redraws so slowly as to make it unusable.  Maybe this is a video 
driver problem instead of a Tux Racer problem?  Tux Racer runs just fine on 
this same machine under Libranet (using genuine NVidia driver).


Version-Release number of selected component (if applicable):
Version packaged with Fedora Core Test 3.

How reproducible:


Steps to Reproduce:
1. Install Fedore Core.
2. Accept default nv driver as recommended during install.
3. Play TuxRacer.
    
Actual results:
Mouse movement and screen redraw are so sluggish that this game is unusable.

Expected results:
Nice fluid motion and screen redraws.

Additional info:
2 GHz Celeron on genuine Intel motherboard; 256 MB RAM, GeForce 4MX video card 
w/ 64 MB; 7200 rpm harddrive (i.e., this isn't a screamer, but it should easily 
be capable of playing TuxRacer).

I'm not certain what driver Fedora is including for nVidia cards, but I'm 
guessing this driver lacks support for 3D acceleration.  It would be nice if 
the driver installed by the setup program supported 3D acceleration.
Comment 1 Mike A. Harris 2003-10-21 02:02:58 EDT
It's not a video driver bug nor a tuxracer bug.  Tuxracer is an OpenGL 3D
game and requires a 3D accelerated video driver in order to function at
a useable speed.  The open source "nv" driver included with XFree86 is
2D only and does not support 3D acceleration, and most likely never will
support it, because Nvidia will not release the documentation to open source
developers which is required in order for 3D to be supported.


>It would be nice if the driver installed by the setup program supported
>3D acceleration.

That's only possible if Nvidia implements 3D acceleration support in the
open source "nv" driver themselves and contributes it to XFree86.org for
a future release, or if Nvidia allows developers to have access to their
technical specifications that are required in order to write 3D support,
and someone volunteers to write 3D support.  Neither of those are likely
to ever happen.

If you are using Nvidia hardware and require 3D acceleration support, you
really have no option but to download 3D capable binary only drivers directly
from Nvidia, which really is not any different from what you'd have to
do if you were using Windows XP.

Note that Red Hat does not support Nvidia's binary proprietary drivers either,
so if you experience problems while using them, please see bug #73733 and
report any problems you encounter directly to Nvidia so they can fix them
when they make future driver releases.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.