This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 107601 - grep supports showing coloured matches but it's not enabled by default
grep supports showing coloured matches but it's not enabled by default
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: grep (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-20 18:33 EDT by Matt Perry
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 04:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Perry 2003-10-20 18:33:56 EDT
Grep supports showing matches in a colour since RedHat 7.3 but it's not enabled
by default like colour support in "ls" is.  These attachments can go in
/etc/profile.d and will set the aliases for grep to show coloured matches.

Version-Release number of selected component (if applicable):
grep-2.5.1-17
Comment 1 Matt Perry 2003-10-20 18:36:12 EDT
Not worth making attachments, I guess. 

Put this in /etc/profile.d/colorgrep.csh:

  alias grep 'grep --color=tty'


Put this in /etc/profile.d/colorgrep.sh:

  alias grep='grep --color=tty' 2>/dev/null
Comment 2 Tim Waugh 2003-10-21 04:59:43 EDT
Guaranteed that as soon as this happens there will be bug reports saying to turn
it off.  This is a user preference thing I think.

Note You need to log in before you can comment on or make changes to this bug.