Bug 107606 - modversions.h requires _ver_str from rhconfig.h
modversions.h requires _ver_str from rhconfig.h
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
http://dxr3.sourceforge.net/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-21 01:05 EDT by Chris Seawood
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 04:20:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Workaround for remap_page_range discrepancy (1.97 KB, patch)
2003-10-21 01:07 EDT, Chris Seawood
no flags Details | Diff
build log (3.47 KB, text/plain)
2003-10-21 01:09 EDT, Chris Seawood
no flags Details
Fix for _ver_str problem (385 bytes, patch)
2003-10-21 01:11 EDT, Chris Seawood
no flags Details | Diff

  None (edit)
Description Chris Seawood 2003-10-21 01:05:32 EDT
Description of problem:
The _ver_str macro is being used without being defined when compiling the
external em8300 kernel module.

Version-Release number of selected component (if applicable):
2.4.20-20.9

How reproducible:
Download the em8300 0.13.0 release from http://dxr3.sourceforge.net/
Apply the attached patch (to workaround another RH-vs-stock kernel discrepancy)
cd modules && make
Comment 1 Chris Seawood 2003-10-21 01:07:47 EDT
Created attachment 95333 [details]
Workaround for remap_page_range discrepancy
Comment 2 Chris Seawood 2003-10-21 01:09:47 EDT
Created attachment 95334 [details]
build log
Comment 3 Chris Seawood 2003-10-21 01:11:02 EDT
Created attachment 95336 [details]
Fix for _ver_str problem
Comment 4 Arjan van de Ven 2003-10-21 03:18:29 EDT
If you look careful that include is already there unless you did something to
trash your installed kernel tree.
If you have a plain kernel-source that is present.
If you mess with it then yes it may be corrupt.

Please use rpm -V kernel-source to verify your kernel tree is in a correct state.
Comment 5 Chris Seawood 2003-10-21 04:18:05 EDT
Oops!  After reinstalling the kernel-source rpm, I see the line there. Hrm.  Oh,
I think I know what the problem is.  When following the em8300 howto, I copied
configs/kernel-2.4.20-i686.config to .config and ran 'make oldconfig && make
dep' on the kernel tree.  'make dep' regenerated modversions.h without the #include.
Comment 6 Arjan van de Ven 2003-10-21 04:20:18 EDT
The em8300 howto is extremely broken then.....
Comment 7 Chris Seawood 2003-10-21 04:28:57 EDT
Possibly.  So should I file a separate bug on the fact that 'make dep' doesn't
regenerate a usable modversions.h or is the tree provided by kernel-source just
designed to not be touched?
Comment 8 Arjan van de Ven 2003-10-21 04:33:50 EDT
either you touch the tree or you don't.
if you do you have to start by a make mrproper, and then you can build your own
custom kernel from it, which is going to be different from the RH kernel.
You can't "half" do it like the howto tries.

Note You need to log in before you can comment on or make changes to this bug.