Bug 1076183 - (EE) BUG: synaptics.c:2648 in UpdateTouchState()
(EE) BUG: synaptics.c:2648 in UpdateTouchState()
Status: CLOSED DUPLICATE of bug 877464
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
20
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-13 14:06 EDT by Andrew Price
Modified: 2014-03-19 06:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-19 06:50:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Price 2014-03-13 14:06:47 EDT
Description of problem:

Sometimes when I'm using my touchpad and there's a particularly heavy load running on my laptop it gets into a state where it only scrolls using one finger, two-finger scrolling no longer works and tapping no longer works.

Version-Release number of selected component (if applicable):

xorg-x11-drv-synaptics-1.7.1-6.fc20.x86_64

How reproducible:

Seems to happen fairly frequently but I couldn't reproduce it at will, I don't think.

Steps to Reproduce:
1. Run a heavy memory/cpu load on the machine, slowing it down, but continue to use the touchpad for web browsing or whatever. Last time it happened I was running a test suite which uses a lot of memory (causing some swapping but nowhere near OOMing) and CPU time.

Actual results:

The above behaviour occurs, plus this gets printed to Xorg.0.log repeatedly when I try to use my touchpad:

(EE) BUG: triggered 'if (priv->num_active_touches > priv->num_slots)'
(EE) BUG: synaptics.c:2648 in UpdateTouchState()
(EE) 
(EE) Backtrace:
(EE) 0: /usr/lib64/xorg/modules/input/synaptics_drv.so (_init+0xb67) [0x7f561123d677]
(EE) 1: /usr/lib64/xorg/modules/input/synaptics_drv.so (_init+0x2b00) [0x7f5611240ab0]
(EE) 2: /usr/lib64/xorg/modules/input/synaptics_drv.so (_init+0x46a2) [0x7f5611244d12]
(EE) 3: /usr/bin/X (?+0x46a2) [0x48f972]
(EE) 4: /usr/bin/X (?+0x46a2) [0x4b8d22]
(EE) 5: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x392200f74f]
(EE) 6: /lib64/libc.so.6 (__select_nocancel+0xa) [0x39218ec6da]
(EE) 7: /usr/bin/X (?+0xa) [0x46a75a]
(EE) 8: /usr/bin/X (?+0xa) [0x439f8a]
(EE) 9: /usr/bin/X (?+0xa) [0x42850a]
(EE) 10: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x3921821d65]
(EE) 11: /usr/bin/X (?+0xf5) [0x428d01]
(EE) 12: ? (?+0xf5) [0xf5]


Expected results:

Nothing untoward.

Additional info:

Logging out and in again seems to clear up the problem.
Comment 1 Peter Hutterer 2014-03-19 06:50:20 EDT

*** This bug has been marked as a duplicate of bug 877464 ***

Note You need to log in before you can comment on or make changes to this bug.