Bug 1076277 - rpm do not support ipv6 on RHEL6.5
rpm do not support ipv6 on RHEL6.5
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm (Show other bugs)
6.6
All Linux
low Severity low
: rc
: ---
Assigned To: packaging-team-maint
Marek Marusic
:
Depends On: 1075844
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-13 21:40 EDT by Hangbin Liu
Modified: 2015-07-22 03:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: rpm-4.8.0-40.el6
Doc Type: Bug Fix
Doc Text:
The rpm utility was unable to download and install packages the remote locations of which were specified with an IPv6 address and a specific path format. Now, rpm automatically uses the "--globoff" option with IPv6 addresses, which turns off cURL globbing, and allows packages to be properly downloaded and installed in the described scenario.
Story Points: ---
Clone Of: 1075844
: 1198515 (view as bug list)
Environment:
Last Closed: 2015-07-22 03:03:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hangbin Liu 2014-03-13 21:40:38 EDT
Clone to RPM since "rpm -ivh http://[$ipv6_addr]/pakcage_name.rpm" failed but curl support IPv6

+++ This bug was initially created as a clone of Bug #1075844 +++

Description of problem:
curl do not support ipv6 on RHEL6.5

Version-Release number of selected component (if applicable):
# curl -V
curl 7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.14.3.0 zlib/1.2.3 libidn/1.18 libssh2/1.4.2
Protocols: tftp ftp telnet dict ldap ldaps http file https ftps scp sftp
Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz


How reproducible:


Steps to Reproduce:
1. # curl -v -6 http://[2001::1]/
2.
3.

Actual results:
curl: (3) [globbing] error: bad range specification after pos 9

Expected results:
get the html from ipv6 host

Additional info:

rpm use curl to get packages from server, so it will fail if we usr "rpm -ivh http://[$ipv6_addr]/pakcage_name.rpm".

BTW, wget works well.
# wget http://[2001::1]/packages/
--2014-03-13 17:38:19--  http://[2001::1]/packages/
Connecting to 2001::1:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 951 [text/html]
Saving to: ?index.html?

100%[=====================================================================================================================================================================================================>] 951         --.-K/s   in 0s

2014-03-13 17:38:19 (220 MB/s) - ?index.html? saved [951/951]

--- Additional comment from Kamil Dudka on 2014-03-13 07:59:56 EDT ---

You need to use the -g/--globoff option.  Please read the FAQ:

http://curl.haxx.se/docs/faq.html#How_can_I_use_or_to_sp
Comment 1 Panu Matilainen 2014-03-14 07:59:38 EDT
Okay so curl needs --globoff to work with raw ipv6 addresses.
Severity high this is not.
Comment 2 Florian Festi 2014-12-15 10:28:14 EST
See upstream commit 409fa83c94d50ab0c4849b737f2647e1069aea8b
Comment 7 errata-xmlrpc 2015-07-22 03:03:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1452.html

Note You need to log in before you can comment on or make changes to this bug.