Bug 107639 - Sound on line out instead of speaker on Dell Dimension 4600c
Sound on line out instead of speaker on Dell Dimension 4600c
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-10-21 12:52 EDT by Ali Ebrahim
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version: 2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-05-18 02:10:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ali Ebrahim 2003-10-21 12:52:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031014

Description of problem:
When installing Fedora Core 0.95 test3 on a Dell Dimension 4600c, the sound
module is detected as i810_audio. Fedora thinks that its working fine, and
doesn't report any errors. But I'm not getting any sound output (yes, it's not
muted, etc).

The hardware information itself is as follows:
(click on the Home button on the page, it will follow through)

Windows reports that the sound card is a "SoundMAX Integrated Digital Audio" and
it works fine. The sound is provided by an on board chipset.

This chipset has an SP/DIF output as well. Is it possible that its just
directing the sound there instead of the regular audio ports? I couldn't find
any utility in the distribution that would let me check this and change the
setting if needed.

I'm watching this bug report, so if any additional information is needed, just
annotate and I'll try and provide it as fully as I can.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Fedora detects an i810_audio sound module during install.
2. It asks me if I can hear anything.
3. I can't hear anything.

Actual Results:  No sound.

Expected Results:  I should hear some test sound.

Additional info:
Comment 1 Kai Thomsen 2003-10-21 17:25:39 EDT
It could be due to an IRQ routing problem. Have you tried adding the boot 
parameter "acpi=on"?
Comment 2 Ali Ebrahim 2003-10-21 18:39:06 EDT
Just tried this, I get an error during the Interactive Startup phase when loading:

/lib/modules/2.4.22-1.2097.nptl/kernel/drivers/acpi/toshiba_acpi.o: init module:
No such device.

No luck with that.
Comment 3 Ali Ebrahim 2003-10-25 02:00:22 EDT
I can also reproduce this with kernel-2.4.22-1.2105.nptl
Comment 4 Ali Ebrahim 2003-10-25 13:16:54 EDT
I can also reproduce this with kernel-2.4.22-1.2108.nptl
Comment 5 David Pilcher 2003-10-25 20:21:13 EDT
I have this on a Dell 400SC server too.

Same symptoms.   Same driver.
Comment 6 Seth Vidal 2003-11-07 01:20:04 EST
On a 4600c using the 2.4.22-1.2061.nptl kernel on a RHL 9 machine
sound works fine.

One thing I had to do was plug the connection into line out - not into
the speaker jack.
Comment 7 Ali Ebrahim 2003-11-07 20:42:43 EST
As per Seth's comment, I was able to get it to work on line out using
2.4.22-1.2115.ntpl on Fedora Core 1. I'm updating the summary to
reflect that it works on line out instead of speaker.

It's using the i810_audio driver.
Comment 8 Ali Ebrahim 2003-11-07 20:59:29 EST
I just want to add that I appear to be getting proper two channel
sound out of the line out jack.

When I run redhat-config-soundcard, it says the following:
Vendor: Intel Corp.
Model: 82801EB AC'97 Audio Controller
Module: i810_audio

When I click on play test sound, the following happens on line out (in
1. Test sound from right speaker.
2. Test sound from left speaker.
3. Test sound from both speakers simeltaneously.

If I try this with the speaker jack, I get nothing.

Also, there was a typo in my kernel version. I'm using
2.4.22-1.2115.nptl, which is what was shipped with Fedore Core 1.
Comment 9 Ali Ebrahim 2004-05-18 02:10:18 EDT
Fixed in Fedora Core 2. Sound now comes out of the correct speaker jack.

Note You need to log in before you can comment on or make changes to this bug.