Bug 1076414 - gobject-introspection has multilib conflicts
Summary: gobject-introspection has multilib conflicts
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gobject-introspection   
(Show other bugs)
Version: 7.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Colin Walters
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
: 1067837 (view as bug list)
Depends On:
Blocks: 1113520
TreeView+ depends on / blocked
 
Reported: 2014-03-14 10:18 UTC by Daniel Mach
Modified: 2014-07-10 15:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
The gobject-introspection library is not available in a 32-bit multilib package. Users who wish to compile 32-bit applications that rely on GObject introspection or libraries that use it, such as GTK+ or GLib, should use the mock package to setup a build environment for their applications.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-10 15:55:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Mach 2014-03-14 10:18:23 UTC
gobject-introspection has multilib conflicts.
These conflicts often cause installation failures.
It is important to fix them before RC.

Contact release engineering for assistance if needed.

Conflicts:
{
    "gobject-introspection-1.36.0-4.el7": {
        "gobject-introspection-devel-1.36.0-4.el7.ppc64": [
            "/usr/bin/g-ir-annotation-tool", 
            "/usr/bin/g-ir-doc-tool", 
            "/usr/bin/g-ir-scanner", 
            "/usr/share/gir-1.0/GLib-2.0.gir"
        ], 
        "gobject-introspection-devel-1.36.0-4.el7.s390x": [
            "/usr/bin/g-ir-annotation-tool", 
            "/usr/bin/g-ir-doc-tool", 
            "/usr/bin/g-ir-scanner", 
            "/usr/share/gir-1.0/GLib-2.0.gir"
        ], 
        "gobject-introspection-devel-1.36.0-4.el7.x86_64": [
            "/usr/bin/g-ir-annotation-tool", 
            "/usr/bin/g-ir-doc-tool", 
            "/usr/bin/g-ir-scanner", 
            "/usr/share/gir-1.0/GLib-2.0.gir"
        ]
    }
}

Comment 2 Colin Walters 2014-03-17 15:41:39 UTC
*** Bug 1067837 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Mach 2014-03-19 13:36:47 UTC
Added to multilib blacklist.

Comment 9 RHEL Product and Program Management 2014-07-10 15:55:43 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.