Bug 1076434 - Upgrade httpclient and httpcore to 4.2.6
Summary: Upgrade httpclient and httpcore to 4.2.6
Status: CLOSED DUPLICATE of bug 1123873
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Apache Server (httpd) and Connectors
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Mladen Turk
QA Contact: Jan Stefl
Russell Dickenson
URL: https://c.na7.visual.force.com/apex/C...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-14 10:37 UTC by Shaun Appleton
Modified: 2018-12-09 17:38 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-08-29 12:36:02 UTC


Attachments (Terms of Use)

Description Shaun Appleton 2014-03-14 10:37:52 UTC
Description of problem:

A customer hits https://issues.apache.org/jira/browse/HTTPCLIENT-1340, which affects httpclient versions from 4.2.1 to 4.2.4.

The release notes indicate:
HttpClient 4.2.5 (GA) is a maintenance release that addresses a number of issues reported since 
release 4.2.4 including a major bug that can lead to re-use of persistent connections in a inconsistent state.

This is a request to upgrade httpclient and httpcore to 4.2.6 so this is not hit in EAP 6.3.0.


Please let me know if I need to fill in an overall component upgrade tracker bz or anything else.

Comment 1 Shaun Appleton 2014-03-14 11:31:05 UTC
EAP 6.3.0.DR4 has in it:

 httpclient-4.2.1-redhat-1.jar
 httpcore-4.2.1-redhat-1.jar

Comment 7 Shaun Appleton 2014-08-29 12:36:02 UTC
I think this can be closed now as it will be addressed by https://bugzilla.redhat.com/show_bug.cgi?id=1123873 and appear in EAP 6.3.0.CP01

*** This bug has been marked as a duplicate of bug 1123873 ***


Note You need to log in before you can comment on or make changes to this bug.