Bug 10765 - when kpackage starts it suggests re-linking
when kpackage starts it suggests re-linking
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kpackage (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-12 16:49 EDT by Andrea Sterbini
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-06 13:47:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Sterbini 2000-04-12 16:49:44 EDT
When I start kpackage I get the message:

[root@marvin /root]# kpackage
kpackage: Symbol `rpmHeaderFormats' has different size in shared object,
consider
re-linking
Comment 1 suson 2000-05-23 19:32:59 EDT
Seeing the message mentioned, and being very accustomed to building my own
RPM's, I took the provided SRPM and rebuilt using "rpm -ba kpackage.spec". This
eliminates the loader message, but causes a strange behavior. To replicate,
follow these steps: 1)Rebuild the package. 2)Load a RPM which attempting to
install would generate errors (duplicate files, etc.) into kpackage via a
single-click on the package. 3)Do a test install (which generates error
dialogs). 4) Cancel the install. 5)Viola. An errant error dialog results, and
above the RPM section is now an erroneous KISS section. I am going to attempt to
attach xwd files which illustrate the errors.
Comment 2 SB 2000-06-06 13:47:27 EDT
The problem is your kpackage was linked against either a newer or older
version of kde-libs and thus the problems.  Recompiling from SRPMS should
fix it though I suggest updating any older components that may be the
culprate as there is usually a reason a newer version came out ;)

-Stan Bubrouski
Comment 3 Preston Brown 2000-08-29 14:24:12 EDT
fixed for the upcoming release of 7.0.

Note You need to log in before you can comment on or make changes to this bug.