Bug 107653 - NVIDIA linux driver fails to compile due to GCC sanity check failed
NVIDIA linux driver fails to compile due to GCC sanity check failed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc32 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-21 14:59 EDT by Benjamin Baez
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 15:02:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Baez 2003-10-21 14:59:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Trying to install the latest NVIDIA driver:
NVIDIA-Linux-x86-1.0-4496-pkg2.run

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Oct 19 22:40:54 2003

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  no precompiled interface: false
  no ncurses color        : false
  query latest driver ver : false
  OpenGL header files     : false
  no questions            : false
  silent                  : false
  XFree86 install prefix  : /usr/X11R6
  OpenGL install prefix   : /usr
  Installer install prefix: /usr
  kernel include path     : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp site                : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
   4363).  As part of installing this driver (version: 1.0-4496), the existing
   driver will be uninstalled.  Are you sure you want to continue? ('no' will a
   bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
   ke the installer to attempt to download a kernel interface for your kernel f
   rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
   this means that the installer will need to compile a kernel interface for
   your kernel.
-> Kernel include path: '/lib/modules/2.4.22-1.2061.nptl/build/include'
-> Cleaning kernel module build directory.
   executing: 'cd ./usr/src/nv; make clean'...
   rm -f nv.o os-agp.o os-interface.o os-registry.o  nv-linux.o nv_compiler.h *
   .d NVdriver nvidia.o
-> Building kernel module:
   executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/lib/modules/2.4.22-1.
   2061.nptl/build/include'...

   You appear to be compiling the NVIDIA kernel module with
   a compiler different from the one that was used to compile
   the running kernel. This may be perfectly fine, but there
   are cases where this can lead to unexpected behaviour and
   system crashes.

   If you know what you are doing and want to override this
   check, you can do so by setting IGNORE_CC_MISMATCH.

   In any other case, set the CC environment variable to the
   name of the compiler that was used to compile the kernel.

   *** Failed cc sanity check. Bailing out! ***
   make: *** [gcc-check] Error 1
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

Version-Release number of selected component (if applicable):
gcc version 3.3.1 20030915 (Red Hat Linux 3.3.1-5)

How reproducible:
Always

Steps to Reproduce:
1. execute NVIDIA installer
2. Go ahead with compilation although using different compiler
3.
    

Actual Results:  Compilation aborted

Expected Results:  driver should be installed after compiled

Additional info:
Comment 1 Matt Wilson 2003-10-21 15:02:21 EDT
nvidia installer needs to be changed to use gcc32, this is not a bug in Fedora Core.

Note You need to log in before you can comment on or make changes to this bug.