Bug 107661 - (gnome-terminal:xxxx): GLib-GObject-CRITICAL **: file gobject.c: line 1320
(gnome-terminal:xxxx): GLib-GObject-CRITICAL **: file gobject.c: line 1320
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-21 15:56 EDT by Dave Habben
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 18:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Habben 2003-10-21 15:56:14 EDT
From Bugzilla Helper:

Description of problem:
# rpm -q gnome-terminal vte
gnome-terminal-2.4.0.1-1
vte-0.11.10-4

Version-Release number of selected component (if applicable):
gnome-terminal-2.4.0.1-1

How reproducible:
Always

Steps to Reproduce:
1. Start gnome-terminal
2. Select a word by dragging the cursor
3. Close gnome-terminal by the window manager [x] box




Actual Results:  It displays in the terminal window that launched gnome-terminal:

(gnome-terminal:1909): GLib-GObject-CRITICAL **: file gobject.c: line 1320
(g_object_ref): assertion `object->ref_count > 0' failed

Expected Results:  gnome-terminal should close properly with no error messages

Additional info:
Comment 1 Dave Habben 2003-10-22 10:28:02 EDT
I was only able to reproduce this under a KDE session, when I tried it under a
Gnome session it worked just fine.
Comment 2 Dave Habben 2003-11-14 14:14:59 EST
This still occurs in Fedora Core 1, just updating the bug.
Comment 3 Warren Togami 2004-04-14 00:56:32 EDT
Please try yourself, or ask one of your friends, to try to reproduce
this on FC2 development.
Comment 4 Dave Habben 2004-04-28 19:20:26 EDT
The error I reported is fixed, it no longer gives that error message
when closing the window. It does however report a new error upon
launching gnome-terminal in a KDE session in a fresh install of Fedore
Core 2 Test 3:

[root@localhost root]# gnome-terminal

(gnome-terminal:2620): Gdk-CRITICAL **: file gdkgc.c: line 465
(gdk_gc_get_colormap): assertion `GDK_IS_GC (gc)' failed

Steps to Reproduce:
1. Start a KDE session
2. Launch konsole
3. type: gnome-terminal
4. See the error message


Comment 5 Ray Strode [halfline] 2005-05-11 18:15:04 EDT
Fedora Core 1 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.

Note You need to log in before you can comment on or make changes to this bug.