Bug 1076736 - Test case failure: GNOME Shell - Concurrent Logins on ATI Kaveri [1002:1304]
Summary: Test case failure: GNOME Shell - Concurrent Logins on ATI Kaveri [1002:1304]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jérôme Glisse
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-15 00:52 UTC by Vasiliy Sharapov
Modified: 2015-11-19 04:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 04:19:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2198 normal SHIPPED_LIVE Xorg server and driver bug fix and enhancement update 2015-11-19 08:04:34 UTC

Description Vasiliy Sharapov 2014-03-15 00:52:12 UTC
Filed from caserun https://tcms.engineering.redhat.com/run/117767/#caserun_4400562

Version-Release number of selected component (if applicable):
RHEL-7.0-20140214.0

Steps to Reproduce: 
 1. create 3 user accounts
 2. log in to GNOME Shell


 1. switch user to second one
 2. switch user to third one
 3. In every session execute command glxinfo | grep render



Actual results: 
Ctrl+Alt+Fx blackscreens often, but switching is possible with a few retries.

Expected results:
no crash should occur, you should be able to switch between X servers by
ctrl+alt+FX

In none of the outputs of the executed commands shouldn't be shown that the
renderer is llvmpipe or any other software renderer

Comment 1 Ladislav Kolacek 2014-12-15 19:47:05 UTC
Same problem with ATI Thames [Radeon 7500M/7600M Series] [1002:6841]

kernel-3.10.0-216.el7.x86_64
xorg-x11-server-Xorg-1.15.0-29.el7.x86_64
xorg-x11-drv-ati-7.4.0-1.20140918git56c7fb8.el7.x86_64

Comment 5 Vasiliy Sharapov 2015-09-16 20:45:24 UTC
Verified fixed in:
RHEL-7.2-20150904.0
xorg-x11-server-Xorg-1.17.2-8.el7.x86_64
xorg-x11-drv-ati-7.5.0-3.el7.x86_64
kernel-3.10.0-313.el7.x86_64
linux-firmware-20150727-41.git75cc3ef.el7.noarch
mesa-dri-drivers-10.6.5-1.20150824.el7.x86_64

(fastuserswitch was broken in beta1)

Comment 6 errata-xmlrpc 2015-11-19 04:19:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2198.html


Note You need to log in before you can comment on or make changes to this bug.