Bug 107677 - copy-paste doesn't keep new lines
copy-paste doesn't keep new lines
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-21 18:23 EDT by Marius Andreiana
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-02 14:11:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2003-10-21 18:23:56 EDT
Steps to Reproduce:
1. copy-paste a message from evolution preview pane (inbox, sent..) in gedit
    
Actual results:
new-lines are lost, all message is in one line

Expected results:
proper copy paste (basic requirement for a desktop!)
Comment 1 Douglas Furlong 2003-10-23 11:23:01 EDT
I am not sure if this is of any help. However.

I am also Running Redhat 9, and have run in to similar problems with the
Evolution that has been updated by Ximian.

A machine that has this problem has evolution-1.4.5-0.ximian.6.0 installed.
A machine that does not have this problem has evolution-1.4.3-0.ximian.6.1
 installed.

Hopefully this is of some assistance.
Comment 2 Jeremy Katz 2003-10-23 16:30:45 EDT
Reproduced
Comment 3 Dave Maley 2003-12-12 11:22:52 EST
I was doing a bit of digging on this one since it's quite an annoying
little bug :(  

Looks as if this may actually be a gtkhtml bug:

   http://bugzilla.ximian.com/show_bug.cgi?id=52052

Hope this helps.
Comment 4 Cott Lang 2003-12-17 23:55:59 EST
This is still a bug in Fedora Core 1. It's a pretty significant one,
since Evolution is the primo mail client and cutting and pasting are
somewhat helpful in the course of the day. :)
Comment 5 Colin Charles 2004-06-30 20:48:22 EDT
Seems to work for me in Fedora Core 2, seems like a bug fixed in the
CURRENTRELEASE
Comment 6 Dave Malcolm 2004-07-02 14:11:07 EDT
This was a bug in gtkhtml3, which Evolution uses to display and edit
emails, and it was fixed in version 3.0.10; and hence for FC2;
resolving as CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.