Bug 107682 - openssl crashes when generating a key for a CSR
openssl crashes when generating a key for a CSR
Product: Red Hat Linux
Classification: Retired
Component: openssl (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-10-21 19:27 EDT by Eve Kovacs
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-04 11:02:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eve Kovacs 2003-10-21 19:27:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I tried to generate a CSR using the Makefile in /usr/share/ssl/certs
When it gets to the point where it tries to generate a key, I get the following
/usr/bin/openssl req -new -key gate.key -out gate.csr
Enter pass phrase for gate.key:
unable to load Private Key
25009:error:06065064:digital envelope routines:EVP_DecryptFinal:bad
25009:error:0906A065:PEM routines:PEM_do_header:bad decrypt:pem_lib.c:421:
make: *** [gate.csr] Error 1

I tried this on a RH 8 system also, with the same result.
The version of opensssl that is installed is:


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.cd /usr/share/ssl/certs
2.make xxx.csr
3.enter pass phrases as propmpted.

Actual Results:  It crashes when you enter the pass phrase for the xxx.key.

Expected Results:  Should have generated xxx.csr

Additional info:
Comment 1 Tomas Mraz 2005-02-04 11:02:29 EST
It works fine for me on the current Fedora Core.

Note You need to log in before you can comment on or make changes to this bug.