Bug 107686 - metacity switched to click-to-focus without asking me.
metacity switched to click-to-focus without asking me.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-21 21:47 EDT by Dams
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 15:25:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2003-10-21 21:47:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1) Gecko/20031014
Galeon/1.3.9

Description of problem:
After some days, metacity dropped the sloppy focus mode and start using
click-to-focus but I never asked for this to change.

Immediatly after metacity changed this behaviour, i ran gnome-window-properties,
but it was still telling me 'on mouse over focus -> on'. I tried to switch to
click-to-focus, close the gnome-window-properties, then to re-run
gnome-window-properties, to go back to sloppy focus but it didnt work.

a 'killall metacity' solved the problem.

It happened 3 times during the last month, and i have not been able to reproduce
it..

Version-Release number of selected component (if applicable):
metacity(0:2.6.2-1).i386

How reproducible:
Sometimes

Steps to Reproduce:
I have not been able to reproduce it.

Additional info:
Comment 1 Dams 2003-11-11 00:59:43 EST
It just happened with metacity(0:2.6.3-1).i386 on FC1
Comment 2 Ben Stringer 2004-02-16 23:06:21 EST
I have observed the same and would love to see this fixed. It almost
always bites me by passing keystrokes destined for a terminal window
through to my evolution window instead, with nasty results.

I am also using metacity-2.6.3-1 on FC1.
Comment 3 Havoc Pennington 2004-05-25 15:25:07 EDT
This is one of those "mysterious cosmic radiation" sort of bugs...
hard to know where to start.

Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=143152

Note You need to log in before you can comment on or make changes to this bug.